powered by Jive Software

Openfire Unable to create a socket connection to XMPP domain


#1

Hello, good day to everyone, I hope you can help me
I try to connect two accounts from different servers with the same domain

i have:
3 virtual machine, 2 with openfire and 1 with a DNS server (Bind9)

  • host1.domain.com- server openfire 1
  • host2.domain.com- server openfire 2
  • host3.domain.com- server dns

Ubuntu 16.04.6 LTS
Openfire 4.2.3
Pidgin 2.12.0

when joining a chat room, from another server, this error comes out

Openfire

jivesoftware.openfire.net.SocketUtil - Unable to create a socket connection to XMPP domain 'conference.host2.domain.com' using remote host: conference.host2.domain.com:5269. Cause: conference.host2.domain.com (a full stacktrace is logged on debug level)
jivesoftware.openfire.net.SocketUtil - Unable to create a socket connection to XMPP domain 'conference.host2.dorcineqc.com': Unable to connect to any of its remote hosts.
jivesoftware.openfire.session.LocalOutgoingServerSession[Authenticate local domain: 'host1.domain.com' to remote domain: 'conference.host2.domain.com'] - Unable to authenticate: Fail to create new session.

DNS named.conf.local

zone "host3.domain.com" IN {
        type master;
        file "/etc/bind/forward.domain.com";
};
zone "X.XXX.XXX.in-addr.arpa" IN {
        type master;
        file "/etc/bind/reverse.domain.com";
};

“reverse” and “forward” They are copies of “db.local”,
DNS forward.domain.com

_xmpp-client._tcp       IN      SRV     10      10      5222    host1.domain.com
_xmpp-server._tcp       IN      SRV     10      10      5269    host1.domain.com

_xmpp-client._tcp       IN      SRV     10      10      5222    host2.domain.com
_xmpp-server._tcp       IN      SRV     10      10      5269    host2.domain.com

DNS reverse.domain.com

XX.X.XXX.XXX.in-addr.arpa.      IN      PTR     host1.domain.com
XX.X.XXX.XXX.in-addr.arpa.      IN      PTR     host2.domain.com

#2

Is it a requirement to use 4.2.3? Maybe you can use the latest version - 4.3.2.

I understand that you want to use Server 2 Server connection. Have you enabled S2S on both servers and added another server to white list on each of them?

Also, DNS entries should have a domain in them, because client won’t be able to find a host without a domain. Say:

_xmpp-client._tcp.domain1.    IN      SRV     10      10      5222    host1.domain.com
_xmpp-server._tcp.domain1.   IN      SRV     10      10      5269    host1.domain.com

_xmpp-client._tcp.domain2.    IN      SRV     10      10      5222    host2.domain.com
_xmpp-server._tcp.domain2.    IN      SRV     10      10      5269    host2.domain.com

This way when a client is logging into user1@domain1 it will be able to find host1.domain.com host to login. And when joining room2@conference.domain2.com it should find host2.domain.com.

For S2S to work you need two different XMPP domains. Say: abc.example.org and def.example.org are considered two different XMPP domains.


#3

Thank you very much for the help and answer, follow the same mistakes, I will think I can do with this.