powered by Jive Software

Openfire upgrade failed - Windows Uninstall fails - looking for uninstaller

Yes, I can get into the Admin console. I am able to do so after running the setup/install as well as after copying the database files over.

After the install, just the regular / bare minimum is shown…

After copying the database, all of our groups and users are in openfire - so the copying and pasting the database is working

I also tried an older copy of the database from when spark was working and it did not help.

Here is the flow of what I have been doing:

Stop openfire service

uninstall open fire

reboot

install open fire

start openfire

log into admin to confirm it is working

exit admin

close openfire

stop openfire service

copy old database files that were in …Openfire\embedded-db\

openfire.properties

openfire.script

Start openfire

log into admin to confirm users and groups are loaded

something appears to be blocking or refusing the Spark user

Thank you for your help.

Ric

You said there was nothing in Spark’s error log, but maybe it logs something in the warn log?

the most recent event in the warn.log is from January. Spark/Open fire only stopped working this month.

2016.01.26 14:29:26 org.jivesoftware.database.SequenceManager - Autocreating jiveID row for type ‘25’

all of the other log files have dates of January or December from when we first installed it.

Thanx.

Ric

Well, i’m out of ideas now. You can save the current install and try completely fresh install, create one user and try logging with a Spark. This will show if this is a problem with your Openfire or the server/connection/network maybe.

I figured this was a sticky problem so thanx for all of your help and ideas.

I’ll try a completely new install and check my notes from the first time we got this up and running.

Thanx!

Ric

working on installing from scratch but hit a snag

Uninstalled Openfire from the server including removing the C:\Program Files\Openfire directory

Uninstalled Spark

Installed and reconfigured Openfire (with one user - mine)

Installed Spark on my client computer however it still remembers the old user ID and is trying to login and failing automatically.

How do we remove the old data from the Spark/client computer?

Thank you

Ric

BTW: it seems like something is blocking all atempts of the Spark Clients from accessing the server.

UNC access works fine

Ric Tucker wrote:

How do we remove the old data from the Spark/client computer?

Delete or rename C:\Users\username\AppData\Roaming\Spark\

Ric Tucker wrote:

BTW: it seems like something is blocking all atempts of the Spark Clients from accessing the server.

Firewall? Try disabling it. It should allow incoming TCP connections on 5222 port.

removed the folder and files in C:\Users\username\AppData\Roaming\Spark\

Disabled the Windows Firewall did not help

We use a frontline firewall so we do not have or need a firewall on the server or other workstations for that matter.

Removed Symantec Endpoint protection from the client station to see if the built in firewall in SEP might be blocking Spark/Openfire

I have our outside service that manages the frontline firewalls checking to see if port 5222 is open

starting Openfire manually gave an error at the end

Openfire 4.0.3 [Sep 29, 2016 2:49:51 PM]

Admin console listening at:

http://user1000:9090

https://user1000:9091

Error starting 5222: Address already in use: bind

The issue has been “resolved”, more to the point I found a workaround.

Since Openfire appeared to be rejecting credentials from any Spark user on any of our computers I uninstalled Openfire and installed in on a spare box. As it happens the boxes name is user10000 (the one we want it on is user1000)

It worked! Spark Clients are able to login to the new server at user10000

Something must be blocking inbound requests on user1000 even though port 5222 is open, there is no active firewall or antivirus either.

Strange but at least we have Spark & Openfire back on speaking terms. Eventually I need to find another box to put openfire on because user10000 is powered on solely for openfire and will eventually need to be placed into service as a production machine.

Thank you for your help!

Ric

BTW: after installing and testing the setup on the new box I then copied the embedded-db files to the new setup and it’s running with all of the old settings, users and groups.

I think the issue with the first box was not a firewall/av blocking the incoming connections, but rather some other app already using 5222 port. Anyway. Yeah, it should work when copying old database into new installation. Just make sure to use same domain name for your server. If your old domain was user1000 and now your users login using user10000 as a login server/domain, then it can create problems when wanting to use encryption (SSL\TLS). Certificates won’t match domain name used to login. This will cause “Certificate hostname verification failed” error with Spark 2.8.x.

P.S. frontline firewall won’t protect against malware which is already inside your network. Having firewalls inside is also a good thing

It does sound like something grabbed and is using Port 5222 on the original box.

Unfortunately the machine name of user1000 assigned to the first box must remain there. If we changed it two other mission critical applications would fail to work.

We’ll have to take our chances but for now at least Spark / Openfire is working okay. We are only using it as an internal chat so I do not see an issue with certificates. Currently our Spark clients are running version 2.7.7. I will need to keep the information in mind.

Thanx.

BTW: we have end point protection for client protection. it may not have firewall turned on but as long as a user does not willfully deactivate end point we should be safe. much appreciated.

BTW: please let me know if you can think of a utility or a quick and dirty way of finding out what other app maybe using port 5222 on the first box.

TY

on windows you can do something like

netstat -aon | find “:5222”

then you can look up the PID using tasklist (or task manager)

tasklist | find “1234”

I believe I followed your instructions correctly.

My best guess would have the PID being “3652”

C:\Users\communications>netstat -aon | find “:5222”

TCP 0.0.0.0:5222 0.0.0.0:0 LISTENING 3652

TCP 192.168.0.50:5222 192.168.0.6:51537 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.9:58587 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.11:50394 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.12:49715 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.16:50810 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.18:51658 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.18:51660 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.19:52846 ESTABLISHED 3652

TCP 192.168.0.50:5222 192.168.0.20:61034 ESTABLISHED 3652

Checking C:\tasklist | find “3652”

Shows

WCXMPPServer.exe 3652 Services 0 4,208 K

which appears to be Openfire’s Jabber app

The plot thickens.

Thank you very much for your help!

Ric

openfire service is called “openfire” so it likely you are running some other xmpp server.

Yeap, i haven’t see a process or a service with such name either.

Ahhh, we may have found the culprit.

There should only be Openfire running on that first box!

Thanx!