powered by Jive Software

Openfire Upgrade from 4.0 to 4.1.6 32 bit


#1

I am trying to upgrade our 32 bit, 4.0.3 Openfire server to 4.1.6. But when I complete the upgrade, the spark clients can no longer see the server. I get an error message that the server cannot be found. Is there something else I need to do to prepare the server after the 4.1.6 install? I did launch the Openfire service after the upgrade, but that did not help.


#2

Are you able to login to Admin Console? Anything in the logs? /openfire/logs/all.log


#3

When the install completed, I was not able to log into admin console. Bu I could see that logs. We have since reverted to a backed up copy of the server. So we are currently back to using the 4.0 version.


#4

The logs might still contain some useful info about the problem. Look through it and maybe past some part of it here (better at the date and time of the upgrade).


#5

Ok. I will take a look at the files. But I am not sure if it will work. Again we are running the server from a backup before the install was attempted.


#6

Oh, yeah, you probably have overwritten the log file with the old one. Well, then you can do this when you try to upgrade again, maybe copy the log somewhere and then revert back.


#7

I will attempt the upgrade again this evening. Are there any known issues with upgrading from 4.0.1 to 4.1.6?


#8

By the way, we are deployed on a Win2K8 server. Running 32 bit version. And it is Vitrualized


#9

There shouldn’t be any issues in theory. But as you are updating to 10+ releases version, something can go wrong during the database upgrade. Your server is also 32-bit? If it is 64-bit, make sure you are downloading the 32-bit installer. When running the installer check if it is pointing to your current installation folder. It should first do automatic uninstall of an old version and then install the new one. If you use service, first stop it.


#10

The server is a 64-bit server. But we are running the 32 bit software.


#11

Question. After the upgrade install, do I need to rerun the Openfire service install as well? (Running as windows Service)


#12

I don’t think you need to do it as it probably hasn’t changed for 10+ years. But i was doing this (when we were using Openfire) :slight_smile:


#13

Ok. Will you be around later this evening? I won’t be able to touch the server until after 5:00 PM


#14

It’s almost 11 pm here (Europe). I will go to sleep soon. Will be able to reply in 6-7 hours maybe.


#15

Ok. Hopefully I can get it to work.


#16

I read another thread, and saw that someone was having the same issue. They removed the “openfire-service.vmoptions” file. So I removed the file before the install. Then I ran the upgrade and it worked. But now our webchat is no longer working and I can’t figure out why.


#17

Well, it stopped working somewhere after 4.0.3 release or similar - OF-658. You haven’t mentioned it, so i couldn’t warn you. Fastpath hasn’t been developed for maybe 10 years now. So at some point some change in Openfire made it not compatible with Webchat.

Removing vmoptions file is not necessary, i never did it while upgrading.


#18

removing that file was the only way I could get openfire service going again. So weird. Is there a way to tell what the external URL would be for webchat? I have it working internally. Just forgot how to use the external URL.


#19

No, i haven’t used it.