powered by Jive Software

Openfire with DB2 8.2

I have db2 8.2 (8.1 with fix pack 14) installed. I followd the installation instructions for DB2. However, when I try to connect to it in the setup it fails after a short delay with the following error in the error log:

2007.06.05 16:19:57 org.jivesoftware.database.ConnectionPool.<init>(ConnectionPool.java:75) Error starting conne ction pool.

java.sql.SQLException: No suitable driver

at java.sql.DriverManager.getDriver(DriverManager.java:264)

at org.jivesoftware.database.ConnectionPool.<init>(ConnectionPool.java:69)

at org.jivesoftware.database.DefaultConnectionProvider.start(DefaultConnectionProv ider.java:83)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:459)

at org.jivesoftware.openfire.admin.setup.setup_002ddatasource_002dstandard_jsp._js pService(setup_002ddatas ource_002dstandard_jsp.java:202)… ad infinitum.

I have set the JDBC Driver Class to COM.ibm.db2.jdbc.app.DB2Driver, which appears to be correct for 8.2. The default com.ibm.db2.jcc.DB2Driver fails immediatly with Unable to load the specified JDBC driver.

Any suggestions?!?

Hi,

did you copy the driver.jar or driver.zip file into the libs directory of Openfire?

LG

I copied db2java.zip from /opt/IBM/db2/V8.1/java/ to the libs dir, and checked all perms prior to starting openfire.

I don’'t think I mentioned this is on Red Hat Enterprise Linux ES release 4 update 5, if that helps.

I found that I needed to copy all of the .jar and .zip files from the DB2 SQLLIB\java directory into OpenFire’s \lib directory and then restart OpenFire to get the drivers to work. I then used the default driver that the web page suggested “com.ibm.db2.jcc.DB2Driver” and everything worked fine at that point.

The DB2 configuration instructions are basically wrong. They don’t say to copy all of the .jar files and the “db2java.zip” file.

I haven’t tried those other suggested driver classes. The default one suggested by the wizard is working fine for me.

  • nobidon