powered by Jive Software

OpenFire won't start after YUM update

Hello,

We have been running an OpenFire server that was set up by a previous sysadmin years ago and have never had a problem (which is great!)

This morning, we ran a YUM update and rebooted the server. Now the “openfire” service won’t start.

I don’t see any obvious log location or even know where to start troubleshooting this. Sorry for being such a n00b with this software. Hopefully this is something obvious (or at least more obvious to you than it is to me after my 10 minutes of searching for a solution).

OpenFire package Info:

Name        : openfire
Arch        : i386
Version     : 3.9.1
Release     : 1
Size        : 174 M
Repo        : installed
From repo   : /openfire-3.9.1-1.i386

CentOS version: CentOS release 6.9

Thanks!!

Greetings,

Check out the files in /opt/openfire/logs, in particular, the nohup.out file, which may contain clues.

Getting error “2017.10.02 08:37:47 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: /opt/openfire/plugins/search
java.lang.ClassNotFoundException: org.jivesoftware.openfire.plugin.SearchPlugin”

Looks like it may be this bug: https://issues.igniterealtime.org/browse/OF-739

Not sure how to proceed. I’m going to look into a newer version, potentially, if supported on CentOS 6.9 (maybe from another repo?)

If you have any ideas, I’m open.

Greetings,

I am unsure of your repo issue, whereby your openfire has some customization that is not provided by Ignite Realtime. In general, you can just download the current release RPM and yum upgrade with it.

Well, I learned a lot.

Upgraded OpenFire…no luck.

Now, even worse, it was not logging anything to the error.log file.

BUT, there was a new error file called “nohup.out”. The contents read “nohup: failed to run command `/opt/openfire/jre/bin/java’: No such file or directory”.

So, I went to that location. “java” was, in fact, there, so i tried to run it. I then got this error:
"-bash: ./java: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory"

Googled that error and discovered that glibc was needed. I installed it using “yum install glibc.i686”, started the OpenFire service, and then logged in…

I wonder if this was a combination of issues that my journey resolved independently. I could probably research or think about it more, but I’m off to work.

Thanks for your help akherz!

That error is when you attempt to run a 32bit binary on a 64bit platform.

Do you know if the 64bit binary is a drop in replacement for the 32bit version?

It is up and running now (with the 32bit version of glibc installed), but if it would prevent future issues and help me keep my system “pure 64bit” then I would be willing to try “upgrading” to the 64bit version.

It is not a simple RPM upgrade as you are switching RPM archs and your better option is to install the noarch RPM version and then install a Java-JRE via some yum repository. You can try using this command to upgrade to a noarch RPM

rpm -Uvh --ignorearch openfire...noarch.rpm

1 Like