OutgoingServerSession errors going to google --- How to do I stop the them

I have these errors repeating over and over, how to do I stop them. I do not want my Wildfire Box talking to the outside world. What is causing this? I have restarted the server and to no avail. Suggestions please

2006.11.30 17:50:26 [org.jivesoftware.wildfire.server.OutgoingServerSession.createOutgoingSession(O utgoingServerSession.java:259)

] Error trying to connect to remote server: gmail.com(DNS lookup: xmpp-server4.l.google.com:5269)

java.net.SocketTimeoutException: connect timed out

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(Unknown Source)

at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.SocksSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at org.jivesoftware.wildfire.server.OutgoingServerSession.createOutgoingSession(Ou tgoingServerSession.java:254)

at org.jivesoftware.wildfire.server.OutgoingServerSession.authenticateDomain(Outgo ingServerSession.java:140)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:130)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:40)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:95)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Hey Bill,

I can think of a few things you can do:

  1. Add gmail.com to the black list (if you don’'t want to talk to that specific server)

  2. Detect which user is trying to speak to that server and take some action. For instance, if someone has added a gmail user to his roster then delete it from the roster

  3. Write a PacketInterceptor that will reject any packet sent to a foreign domain

  4. Implement 2 small changes to RoutingTable that will return a null route when trying to send a packet to a remote server (and the s2s service is disabled). Send me your patch so we can make it part of Wildfire.

Regards,

– Gato

How would I go about doing number 2?

Hi,

I do not want my Wildfire Box talking to the outside world.

Did you disable s2s on http://server:9090/server2server-settings.jsp ?

@2: Are you familar with SQL and want to identify the bad boys? Replace “example.com” with your xmpp.domain:

select USERNAME, JID from JIVEROSTER where JID not like ‘’%@example.com’’;

As I have no idea how much Wildfire loves if you use delete instead of select I don’'t recommend you to delete the entries.

LG

I am using the embeded DB

Hi,

so you need to shutdown Wildfire before you change the files, Wildfire comes with the embedded-db viewer (in bin/extra) but you could also use vi/notepad to view and edit wildfire.script (or wildfire.log).

Viewing the values is possible also without the need to shutdown Wildfire. So

cat embedded-db/wi* | grep "JIVEROSTER" | grep -v "@example.com"

should list the interesting result.

LG