powered by Jive Software

Password change procedures for wildfire with embedded db and AD integration

Hello all,

I am running an older version of openfire (wildfire), with the integrated hsql database and Active Directory integration (authentication).

I am now required to change to stronger type passwords.

I noticed in wildfire/config/wildfire.xml that there were the following nodes:

<ldap>

<adminDN>ldapadmin@mydomain.com</adminDN>

<adminPassword>mysimplepassword</adminPassword>

<ldap>

So I tried to change this password in wildfire.xml and also in the active directory like so.

<adminDN>ldapadmin@mydomain.com</adminDN>

<adminPassword>myCOMPLEXpassword</adminPassword>

I allow 1 domain user(belonging to admins group) to log into the wildfire console, this account is called sysadmin . All went well, I stopped wildfire and restarted and then logged into the admin console with the account called sysadmin.I was able to log in successfully.I then rebooted the server and started wildfire and attempted to log into the admin console but was unsuccessful. I tried all passwords but I was locked out completely. Is there other steps to take to change the password of the user that wildfire uses to access active directory (in my case ldapadmin).I did see some posts but none were clear as to all of the steps.[http://www.igniterealtime.org/community/message/149862#149862http://www.ignitere altime.org/community/thread/28597] I will eventually upgrade to openfire.Thanks for any tips.

First thing I would try is change the password for the account again in AD. Then stop the wildfire server, and change the password in the wildfire.xml file again. If that does not work you could configure the wildfire.xml to rerun the setup. Look for the <setup></setup> hashes in the xml file and change teh saved setting to the opposite of what is saved (again while wildfire is not running).