powered by Jive Software

PC Call Problem

Hi all!

I am newbie to Openfire & Spark’s world.

Yesterday I installed OpenFire on CentOS server and today I am enjoying installing, configuring and testing Spark.

I’d like to call other PCs from mine and to do so I followed this guide - http://community.igniterealtime.org/docs/DOC-2187

I also read this http://community.igniterealtime.org/message/211645.

On my OpenFire settings I checked in STUN Settings, Local Server Enabled.

I put as Primary Address the eth0 Ip interface and as Secondary Address the IP of a virtual interface created as alias of eth0. I’ve done this only because in the giude and in the forum wroot said that is needed.

As primaryand secondary port values I leaved the default values.

So I set on two Spark clients in Preferences->Media Settings the IP of my OpenFire server in Stun Server.

The button “Call PC” doesn’t appears.

Can anyone helps me?

Thank you in advance.

I update you about the problem: I managed to call a PC from one PC. I arranged a configuration on STUN server settings using (not the local) but adding others servers in the index in the low part of the page.

I also set “stunserver.org” in STUN client settings.

I also manage to call a mobile phone, through my telephone exchange from a pc, using the SIP Plugin.

I have two problems now:

  1. only one client (not ever the same, but only one at time) gives me the button call pc to pc on the three i have installed to test.

Every client has the same configuration.

  1. The Audio is awful in the communication between two pcs and on the mobile, when a PC call a mobile.

Only on the pc the audio is good in a PC-Mobile communication.

Awful means that the level of sound goes down every second for a while and seems that there is a sort of echo a the end of communication, that is terminated only after Spark shutdown.

Do you know how to solve these two problems.

Thank you very much.

I hope that this project isn’t abandoned how it seems, because it’s a very great software.