powered by Jive Software

Permissions required to Spark directory under Windows?

I have published Spark 2.5.5 via a GPO to a group of users. One of them installed the app, which was successfully installed, but when they tried to run it the egg timer appeared briefly but then immediately disappeared. I used RunAs to run it under my account but had the same problem, so then I used RunAs to run it under an Administrator account, whereupon it loaded successfully and once closed worked correctly for both myself and the other user.

This suggests to my mind that a file or registry entry is written upon first load that a standard user account does not have access to. Where abouts would this be, so I can change the permissions to allow anyone to launch the app?

I used some software to monitor the install and run of spark 2.5.5 install. There does not appear to be anything special going on with the registry. Just the normal additions to allow for the uninstall of the application. I do notice though that the program when I first ran it did not show for me either, but a quick check of task manager shows it was running. I quit the process and relaunched spark and everything is fine. My guess is there is a bug in the application itself as this behavior was not present in previous versions. I am currently working with 2.5.5 to build a custom msi deployment for our company, to contain all the extra files to make SSO work correctly. Thus far this appears to be the only issue I see with 2.5.5 of any significance to the end user, other than the issues with the current gateway plugin.

Thanks for the investigation mtstravel. I’ve gone ahead and filed SPARK-827 to see what could possibly be causing this.

Cheers,

Derek

I too saw the process in the background, but killing it didn’t allow me to launch it, the same thing happened it sat in the background. I’ve noticed it’s a bit like Outlook, if you launch it too soon after closing it it has a tantrum.

Hopefully this is a one-off and the next version will squad this.

Hey All,

I cannot seem to reproduce this issue at all. What is the reproducable test case?

Cheers,

Derek

I was able to produce this error on a clean install of spark 2.5.5 on a windows machine that did not previously have spark. Launch spark and the program never comes to the front. Force the process to quit and wait for the process to fully end. Then relaunch the program and all is good. This does not seem to be and everytime thing. Some machines have no issues. All my windows machines are cloned from one image, and all are running a manged firewall.

The problem appears to be linked to the preference to Start in System Tray. If that is enabled with version 2.5.5 on my test machines the program intermitently starts but never puts the icon in the tray. On my machine this happens every time.

Thanks mt. I’m still not able to reproduce this though :(. I have “Start in system tray” and start it up everytime with success. Is this happening maybe on a restart of your computer?

Cheers,

Derek

It does happen after a restart, or an entended period of not running the software. Once it happens I have to quit the app in task manager and wait a little and relaunch. Then sometimes it shows in tray. If I don’t have Start in System Tray enabled it will launch correctly every time. This is version 2.5.5. I did not have this issue with previous versions. I did not have the issue with 2.5.6 either. It seems isolated to version 2.5.5 for me. i noticed this because I have been doing extensive testing for Daniel with the gateway plugin issue, that also seems to have resolved with version 2.5.6 of spark, for my test group at least.

I installed version 2.5.7 through group policy and have the exact issue Quitch reported. I ran the utility “Filemon” and found that several files were trying to be created in this directory: \Program Files\Spark\lib

I granted the local users group modify permissions (though write permissions would have probably been enough) and tried to run Spark again. This time it opened.