powered by Jive Software

Plugin not finding

Hi

I am still testing and working on Jive Messenger 2.2.0. Lately I have been moving Jive from desktop box to the 1U server. During this time I have not properly shut down the mysql and the database got corrupted and not working anymore. So I create a new database with the same name in the same location and I just restarted the jive server. However it is not finding the plugin anymore. I try to reconfigure the server from the begining but I am still not finding the plugin. I remove the plugin folder and plugin jar file one by one but it is still not finding it. If I remove the file and only leave the jar file, the plugin got extracted but it is not loaded into the server.

Here is my debug log

2005.08.29 22:15:39 Connect Socket[addr=/127.0.0.1,port=32990,localport=5269]

2005.08.29 22:15:39 OS - Sent dialback key to host: 127.0.0.1 id: 35dc25e9 from domain: jive.mydomain.com

2005.08.29 22:15:39 RS - Received dialback key from host: jive.mydomain.com to: 127.0.0.1

2005.08.29 22:15:39 RS - Error, hostname not recognized: 127.0.0.1

2005.08.29 22:15:39 OS - Unexpected answer in validation from: 127.0.0.1 id: 35dc25e9 for domain: jive.mydomain.com answer:

2005.08.30 08:46:19 Stopping server

hi wmhtet

don’‘t know if it’'s your case, but i had some problems with some plugins that was in upper case.

try to rename all plugins (.jar files) to lower case, don’‘t know if it’'s because the OS or the Java.

delete the folder in /opt/jive_messenger/plugins/your_plugins and the .jar files and them copy the new ones. the JM will do the rest for you.

anyway, you can try these.

regards,

Rodrigo.

Rodrigo

They are all in lower case and I have tried removing all the file and folder except admin folder and it is not working yet. When I removed everything and download the file again, jive does not do anything to them if jive is running. jive extract them when it start but the plugins do not get loaded.

wmhtet.