powered by Jive Software

Plugins nao carregam

Boa tarde Senhores…

será que alguém já passou por isso?

plataforma Linux - Debian amd64 - sun-java6-jre

quando eu tento carregar algum plugin através do painel e administração ele me retorna a mensagem que foi carregado com sucesso… porem não aparece o plugin na lista.

e no arquivo de log me retorna a seguinte mensagem…

2014.10.07 16:41:15 org.jivesoftware.openfire.container.PluginManager - Error loading plugin: /usr/share/openfire/plugins/monitoring
java.lang.UnsupportedClassVersionError: org/jivesoftware/openfire/plugin/MonitoringPlugin : Unsupported major.minor version 51.0

Creio que o problema possa ser do Java, mas não sei como resolver, alguém tem algo para contribuir?ço

desde já agradeço.

Ola amigo, primeiramente desculpe pela demora em responderem sua pergunta, eu não tenho ambiente linux aqui, mas posso instalar um para ver se consigo simular o mesmo erro, antes disso, você tentou instalar a ultima versão do openfire, java, ou está usando alguma velha?

Caso esteja na ultima, seria uma boa testar com a versão velha do openfire, normalmente, a ultima versão pode dar algumas incompatibilidades com alguns plugins. Então, você pode fazer ambos os testes, caso não esteja na ultima, atualiza, caso esteja na ultima, faz o downgrade de versão, caso não resolva, vou subir uma vm com linux e tentar te ajudar.

Olá Vinicius Gobbi,
obrigado pela resposta satisfatória e a vontade de ajudar.
realmente meu problema foi resolvido, deixe-me deixar registrado caso alguém precise.

meu problema era o java, eu estava usando o sun-java6-jre e a após migrar para openjdk-7-jre tudo funcionou como eu esperava.
“lógico, depois de algumas horas fazendo atualizações e downgrades do openfire e java…”

agradeço novamente pela resposta.

Abraç…

Diorgenes,

Estou com o mesmo problema, e ja fiz o que você mencionou(de migrar do sun-java6-jre para o openjdk-7-jre) mas não funcionou, instalo os plugins mas não aparecem.

Alguém sabe de outra solução?

Ta rodando em cima do Debian6 com openfire_3.9.1_all.deb porque com a versão mais nova do openfire, o sparkweb não funciona.

Boa tarde Ageu,

seguinte… verifique se a mensagem de log é a mesma que eu postei ali em cima e me retorne…

outra coisa…
desinstale o openfire e o openjdk-7-jre usando o comando apt-get --purge remove openjdk-7-jre openfire e depois execute apt-get autoremove
após fazer isso rode o comando find / -name openfire e apaque qualquer vestigio, a menos que esteja usando o mysql, dai nao exclua o Banco de dados.


agora instale o java
apt-get install openjdk-7-jre
agora baixe e instale o openfire atualizado
**wget http://download.igniterealtime.org/openfire/openfire_3.9.3_all.deb **
dpkg -i openfire_3.9.3_all.deb

se aparecer alguma erro nesse passo, me avise.
tente acessar o admin web
localhost:9090
configure conforme sua necessidade e tente novamente carregar o plugin…

Boa Noite Diorgenes,

Só corrigindo… “Tá rodando em cima do Debian 7 Wheezy 3.2.0-4-486 i386”

Fiz os procedimentos que postou e realmente funcionou! Os plugins já aparecem! Tudo redondinho

No meu servidor já tava meio bagunçado, tinha vestígios do sun-java6-jre nele e ai eu removi(apt-get --purge remove sun-java6-jre) em seguida o (apt-get autoremove);

Depois fiz o que você tinha dito, instalar o (apt-get install openjdk-7-jre) e depois o (dpkg -i openfire_3.9.3_all.deb) e ai tudo ficou certinho.

Agora o servidor está desse jeito:

Debian 7 Wheezy 3.2.0-4-486 i386 + openjdk-7-jre + openfire_3.9.3_all.deb + sparkweb_0_9_0

Mas agora tem dois probleminhas… Não consigo fazer o Sparkweb funcionar, as vezes ele retorna a mensagem de “Not authorized. Please try again.” e outras vezes quando ele testa logar a tela do navegador da um “refresh” e em seguida volta pra tela do login. Quando tava com esse bug eu voltei pra versão 3.9.1 do openfire e ai tinha resolvido, mas agora que atualizei novamente o problema retornou.

Você usa o sparkweb?

Desde já,

Muito Obrigado!

Ageu

Olá Ageu,

eu não uso o sparkweb pois acho o client Spark instalado na maquina muito mais versátil…

vou subir uma VM para testar e posto aqui o resultado.

Ta ok Diorgenes,

Fico no aguardo!

Abs