powered by Jive Software

Plugins problem

Hi, I’'m just evaluating “Jive Messenger, Version: 2.3.0” and have downloaded some plugins (eg Asterisk-IM, search etc.)

The docs say to put them into the plugins directory, which I have done. They do not get unpacked until I restart the Jive server, and also they do not appear in the plugins list in the admin console.

The debug log indicates that it has unpacked the files, but does not show any plugins being started/enabled apart from the admin… as shown below:

2005.11.22 22:04:58 Loading plugin admin

2005.11.22 22:09:30 Stopping server

2005.11.22 22:09:48 Extracting plugin: asterisk-im

2005.11.22 22:09:49 Loading plugin admin

2005.11.22 22:10:51 Stopping server

2005.11.22 22:11:16 Loading plugin admin

2005.11.22 23:47:33 Stopping server

Do I have to set any extra configuration parameters anywhere?

I’‘ve never had to do anything more than what you have described. Have you tried any of the other plugins? I only see from the log that it’‘s trying to extract the Asterisk-IM plugin. I’‘ve not used the Asterisk-IM plugin so i can’'t say if it worked on previous version but not this one.

It’'s possible that the Asterisk-IM plugin is having issues with the 2.3 code base.

I’'m going to download the Asterisk-IM plugin and see if i can load it on my system now.

I just loaded that plugin and it extracted and loaded into the admin console without me even having to restart the server.

2005.11.23 09:10:08 Initializing Asterisk-IM Plugin

2005.11.23 09:10:08 Initializing Hibernate for Asterisk-IM

2005.11.23 09:10:13 Checking to see if Asterisk-IM database schema is present

2005.11.23 09:10:13 Installing Asterisk-IM database schema

2005.11.23 09:10:13 Installing phone plugin database

2005.11.23 09:10:14 Initializing Asterisk-IM thread Pool

What OS are you running this under? Are there any other entries in the other logs?

hi there:

same problem here, plugin list doesn’‘t show them I’‘m running slackware linux 10.0. I also have another issue: if i change settings on admin console, stop server and restart it, they are not saved. I’'m using LDAP for user authentication.

No, I’'ve tried all of the public plugins on the download page, all they seem to do is unpack, and then only on a reload

I’'m running it on linux - debian, 2.4.7 (with openwall security patches) and SMP

java -version

java version “1.5.0_05”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)

Java HotSpot™ Client VM (build 1.5.0_05-b05, mixed mode, sharing)

(bump)

Anyone else got any suggestions? perhaps to force the plugins to load or to enable more verbose logging ?