powered by Jive Software

Plugins went AWOL after upgrading to RC1

So I did a fresh Slackware box and installed JM2.2.0RC1

Now I noticed 2 plugins missing. Content Filter and Import/Export

I have the JARs in the plugins folder but they wont come up in JM2 Admin.

Did I miss the memo or are my plugins AWOL?

Thanks

Peter

I have the same problem with Content Filter

Hi Guys,

I just tried installing a clean copy of 2.2 RC1 with the search, content filter and user import/export plugin and they all came up ok. Are you seeing any errors in your logs?

Thanks,

Ryan

Here’'s a block from my error log that looks kinda relevent…

2005.08.01 04:36:43 org.jivesoftware.messenger.container.PluginManager.loadPlugin(PluginManager.java :341) Error loading plugin

java.lang.ClassNotFoundException: org.jivesoftware.messenger.plugin.ImportExportPlugin

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at org.jivesoftware.messenger.container.PluginClassLoader.loadClass(PluginClassLoa der.java:119)

at org.jivesoftware.messenger.container.PluginManager.loadPlugin(PluginManager.jav a:272)

at org.jivesoftware.messenger.container.PluginManager.access$200(PluginManager.jav a:49)

at org.jivesoftware.messenger.container.PluginManager$PluginMonitor.run(PluginMana ger.java:628)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

If this is not what you looking for email/pm me and i’'ll keep digging.

Peter

Hi Peter,

Could you try removing the import export plugin and restarting the server? One plugin failing to load shouldn’‘t affect any of the other plugins but I’'m wondering if that is the case here. Which version of the user import export plugin are you using?

Thanks,

Ryan

Ryan,

I mv’'d userImportExport out of the plugins folder and restarted JM.

Same situation, content filter is missing.

As for versions, everything was a fresh D/L yesterday from the plugins page.

Here is my plugin folder

-rw-rr 1 jive jive 10276 2005-06-05 21:29 broadcast.jar

-rw-rr 1 jive jive 18575 2005-07-06 16:15 contentFilter.jar

drwxr-xr-x 4 jive jive 4096 2005-07-31 19:59 presence/

-rw-rr 1 jive jive 23084 2005-07-31 19:59 presence.jar

drwxr-xr-x 4 jive jive 4096 2005-07-31 19:55 registration/

-rw-rr 1 jive jive 14432 2005-06-05 21:29 registration.jar

drwxr-xr-x 4 jive jive 4096 2005-07-31 19:55 search/

-rw-rr 1 jive jive 31651 2005-07-03 08:39 search.jar

-rw-rr 1 jive jive 649548 2005-07-03 08:41 userImportExport.jar

Peter

I also tried reversing the test and moved contentfilter out and restart. Same deal…

Peter

Hmm… strange. And the only two plugins that are not working are the content filer and user import export?

Thanks,

Ryan

exactly… do you want in to take a look?

Hi Peter,

I’‘ve tried downloading the two plugins and have built them from source and I haven’‘t been able to reproduce the problem. I wonder if it’‘s possible that the jar’'s were corrupted somehow during the download process. Could you try downloading them again to see if you have the same problem.

Thanks,

Ryan

I am having the same problem, import/export and content filter are not appearing.

I was using Jive 2.1.5 on RH9. upgraded the package using webmin’‘s handy package installer and then both my plugins AWOL’‘d on me as well… if anyone would like some logs or any more info, I’‘m happy to provide. (content filter was never there before the upgrade, but i can’‘t figure out why it’‘s not showing up now that I’'m at 2.2.0)

Thanks!

Brett

Hi Brett,

Interesting that you and Peter are having the same problem when he did a clean install and you did an upgrade. If you want to go ahead and post your logs I can take a look at them.

Thanks,

Ryan

I browsed through them… this line keeps reoccuring -

2005.07.29 10:22:43 org.jivesoftware.messenger.container.PluginManager$PluginMonitor.run(PluginManag er.java:599) Error unloading plugin userimportexport. Will attempt again momentarily.

as well as this set of 4 lines

at org.jivesoftware.messenger.container.AdminConsolePlugin.initializePlugin(AdminC onsolePlugin.java:130)

at org.jivesoftware.messenger.container.PluginManager.loadPlugin(PluginManager.jav a:269)

at org.jivesoftware.messenger.container.PluginManager.access$300(PluginManager.jav a:57)

at org.jivesoftware.messenger.container.PluginManager$PluginMonitor.run(PluginMana ger.java:611)

I have also made the entire log availible in excel format www.starsystemsonline.com/errorlog.xls

(Please forgive me if it violates rules of forum…)

If you need it in another format, please let me know

Thanks!

Brett

Hi Brett,

Thank you for the log file.

Since I haven’‘t been able to reproduce this problem on Windows and you and Peter are running on Linux I have a feeling that the problem is somehow OS related. Unfortunately, I don’'t currently have Linux box for me to test this on but I will continue to dig to see if I can figure out what is going on.

Thanks,

Ryan

Thanks at least for looking at it =D…

I don’'t really need the user imports, but I imagine someone else might… content filter would be nice though.

I wonder if the content filter just doesn’‘t work for non-windows OS… It’'s never shown up on mine.

I’'ve had installed and working on Slack, it works great!

Peter

Thanks at least for looking at it =D…

I don’'t really need the user imports, but I imagine

someone else might…

like me I’‘m waiting for 2.2.0 release, but i will not upgrade until i’'m not sure it wount break anything.

I wonder if the content filter just doesn’'t work for

non-windows OS… It’'s never shown up on mine.

content filter’'s beta version worked on mine Archlinux box at least. With JM 2.1.5.

content filter’'s beta version worked on mine

Archlinux box at least. With JM 2.1.5.

Really? Are you sure about that? The content filter requires 2.2.

Thanks,

Ryan

Ryan, i’‘m talking about early testing version of content filter, and it was working with 2.1.5, i have tested it with my users at work (2.1.5 still). Only after some time Gato has added some additional code to JM to improve content filter’'s functionality. So now it requires 2.2.x

Hi everyone.

I’'m also having problems with the contentFilter.jar and userImportExport.jar not deploying.

2005.08.04 11:53:07 Extracting plugin: userimportexport

2005.08.04 11:53:07 Extracting plugin: contentfilter

2005.08.04 11:53:07 Unloading plugin contentfilter

2005.08.04 11:53:07 Unloading plugin userimportexport

repeats over and over.

I’'m running redhat 9

Linux host86.objectsciences.com 2.4.20-31.9custom #3 SMP Thu Sep 9 16:04:36 EDT 2004 i686 i686 i386 GNU/Linux

java version “1.5.0_02”

Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_02-b09)

Java HotSpot™ Server VM (build 1.5.0_02-b09, mixed mode)

Jive Messenger 2.2.0 release, and all the plugin version from the plugins download page.

I played around and found out that if I rename the contentFilter.jar to contentfilter.jar it would deploy. The same thing worked for renaming userImportExport.jar to userimportexport.jar. So it seems something in the name of the plugins that containing mixed case jars refuse to deploy under my Linux configuration. I could see how this wouldn’‘t affect a Windows installation test since it’'s not case sensitve.

Regards,

Ed