powered by Jive Software

Ports being blocks can''t access server

After help from you guys, I now have a live help running on my website and through a jive server. Which all works brilliantly.

The problem I have found since I made it public is that some people trying to access it from certain places (mainly big companies) and finding that they cannot access the chat as the port has been blocked by their IT guys.

I am running the server with client port 5222. Is there any way I can get around the firewall at there end, i.e using a port that is open such as 80 or 25, or http tunnelling??

After all this work it would be very unfortunate if I was unable to use it.

Any help on this matter would help greatly.

Thanks

Iain Freestone.

Hi Iain,

Darn those pesky IT guys.

While I wouldn’‘t promote ways to circumvent certain companies IT policies I will tell you that nearly every XMPP/Jabber client and server I’'ve come across can be configured to use a port other than 5222 to communicate with one another. There are even public servers, like url=http://www.jabber80.com/Jabber80[/url] that are setup to run non-standard ports.

To change the port Messenger uses sign-in to the Admin Console and go to Server -> Server Manager -> Server Settings and use the Edit Properties button.

Hope that helps,

Ryan

Hi Ryang,

I have been trying that and have tried changing the jive server port number to numberous different numbers i.e 443 and some others then allowing access on the firewall to this port. Afterwhich I changed the port that my IM client is using (exodus) but even I can’'t connect then, the only ports I seem to be able to connect to are 5222 and 5223 using SSL.

I am running the jive server on Mandriva 10.1 2005 Limited edition. My online chat app is Flash based using XMPP and we are using Exodus on Windows machines as our IM Clients.

Any ideas?

Cheers

Iain

Hi Iain,

Sounds like there is something not quite configured properly on your firewall. I just tried setting up Exodus (and Psi) to connect to Messenge using port 80 for client connections and port 81 for client SSL connections and didn’'t have any issues.

Are you able to see the traffic attemping to go through your firewall? What sort of error messages are you seeing with Exodus?

Thanks,

Ryan