powered by Jive Software

Presence doesn''t work

Dear wildfirers,

Has anybody else found that presence only updates when signing in. Using both gaim and spark against users from LDAP, the buddy/contact list only show the presence of each member at login time. The presence doesn’'t update after that.

IM works fine. Even when starting a conv with a user whic happears offline.

web interface show correct state of the users.

Cheers

Rob

wildfire latest (as of 4th sept)

Java 1.5.0

Sun Solaris 10 u1 x86

Yes, I’'m having the exact same problem, using Wildfire 3.1.0b and Spark 2.0.0 and 2.0.1.

The presence plugin also doesn’'t seem to be working correctly.

Are you using LDAP with MS Active Directory?

Same here.

Should be a small fix. Hopefully the guys can get to it before the 3.1.0 release.

The changelog for 3.1.0b2 doesn’‘t mention this as being resolved, so I assume it’'s still a problem. In the meantime, reverting to 3.0.1 has fixed the problem for us.

Hey guys,

Could you tell me if you are using LDAP or not? I would highly appreciate if you can provide me a step-by-step to reproduce this problem. Could you log into the admin console and check that groups have the correct list of members. BTW, I’'m in the middle of my relocation so my response time may not be optimal.

Regards,

– Gato

I am using LDAP with Microsoft Active Directory. I have two servers specified. Here is my wildfire.xml config file:


[ldap 1], <![CDATA[

(&

(objectClass=user)

(memberOf=CN=[IM users],OU=[user container],DC=[domain],DC=[domain],DC=[domain])

(!(userAccountControl:1.2.840.113556.1.4.803:=2))

(sAMAccountName=)
)
]]> <![CDATA[
(&
(objectClass=group)
(memberOf=CN=[IM users],OU=[user container],DC=[domain],DC=[domain],DC=[domain])
(member=)

)

]]>


I was previously using the embedded database with Wildfire and it didn’'t make any difference. I have tried with Wildfire 3.1.0 beta 1 using Spark 2.0.0 beta 2 (? the last beta), Spark 2.0.0 and Spark 2.0.1. It seems to have resolved itself with Wildfire 3.0.1 but after a day I am not 100% convinced that is the case – it seems a lot better with Wildfire 3.0.1 but not totally resolved.

Using LDAP against AD exactly as specified in the docs. Nothing special. Group membership is correct both on the clients and admin console. The only issue is visibility.

If it helps, I think the problem is on line 128 of Roster.java.

When you’‘re checking to see if 2 users have mutual visibility via shared groups, you’'re using “userGroups” instead of “sharedGroups” in the call to hasMutualVisibility. When I correct it and rebuild, it works fine.

george

Message was edited by: gtj

BUMP. There’'s a few of us with this problem.

We are on the verge of a major rollout, and have stumbled on this one… Any fix insight??

hey, can i have a copy of your modded build, im struggling here, java builds are very new to me, I’'m not sure if ill get it right.

please

I too have the same problem… I’'ve been having it since version 2.3.0… Currently on 3.0.1 and am getting frustrated… If the previous user can post his modded file it would be a huge help… Thanks…

I’'m asking for permission now.

Gato checked in some fixes today. I just did a clean build from that and presence is now working. Wait until tomorrow and grab tonight’'s nightly build.

We just released 3.1.0 Beta 3, which includes Gato’'s fix.

Thanks,

Matt

Are you guys positive 3.1.0b3 fixed this issue? I just installed it over the top of our 3.0.1 install using our same configuration and database and all the users completely disappeared from the roster! Users logging on and off weren’'t visible at all.

In addition, all the groups disappeared from the web admin interface.

Our Wildfire access AD group is a distribution group (local to that domain), and the groups (security global groups, holdover from when it was nt4) are members of the distribution group. I assume ths shouldn’'t have any effect since it worked as expected in 3.0.1.

the only thing i can think of is that i remember during a couple of upgrades my wildlife.xml got restored to default… I never thought of lookin for days… stupid me…

but since i upgraded to 3.1.0 beta 3… everything has worked flawlessly… good job jivesoftware…excellent product…

Hi,

Were having presence problems too. Not usning LDAP, but users seem to be getting stuck ‘‘away due to idle’’ even when there typing messages!

On 3.1.0b3 and have got msn transport running.

I.

ibradshaw,

Gato and I were seeing something similar yesterday and it seemed to be gateway related. We’'re not quite sure what the issue is yet. If anyone can come up with a test case, that would be awesome.

Thanks,

Matt

Hi,

Not sure how to replicate it at the moment, seems to be intermittent and some users only.

Best guess at the moment is that its something to do with dropping the odd packet or something? maybe loosing a presence packet somewhere along the line and its not then retrying as it doesn’'t know its lost???

We all use it remotely (i.e. not on a lan, but always over a wan) and it seems to be more with users on slower connections on providers we know to be dodgy with there line stability. Strange how it’‘s only just sarted with the msn transport loaded tho, as these are spark users on the wildfire server (although they have msn id’‘s associated with there jabber id’'s) as even with the dodgy providers people have had the correct presence before.

May be unrelated, but seems viable… and since its intermittent a possibility???

Don’‘t know how to check that tho - so if you’‘ve got any ideas on what to log then pop it on here and I’'ll give it a go.

I.

I got Wildfire 3.1.0 beta3 running in one of my xen-domains. For testing, I installed a quite old python-bot, which

polls rss-feeds for me and sends new entries to me via im (if anyone has any hints about more recent bots

which can be used for that, please give me a hint).

Until the wildfire test I used jabber1 as a server. Everything worked ok, when I connected in the morning,

I got all the new rss-entries, which had gathered over the night.

With wildfire, I have to restart the bot every time I log on to the server because wildfire does not see the bot

as “online” (although it is up and running). Obviously that is not, what was intended and I switched back

to jabberd1 with that application.

I suspect, that this is a presence-problem, is it?

I was having the same problem with 3.x versions.

I could not figure it out for a long time… then by accident I fixed it.

I am running a redhat variant. The box is named srv1.foxlakecreenation.com. That is what I had in /etc/hosts/

My domain name is foxlakecreenation.com. My web address is www.foxlakecreenation.com. My mail servers are foxlakecreenation.com. everyting just worked like this for years… even though the hosts file is srv1.foxlakecreenation.com.

Today I decided to change srv1.foxlakecreenation.com in the hosts file to the fully qualified domain name of foxlakecreenation.com.

Guess what… the presence started working again.

So my advice to you guys that are having this problem, make sure you wildfire server name matches your name the name in your hosts file. This name must also be reachable from the internet… no just your LAN.

In my case srv1.foxlakecreenation.com is reachable on the LAN, but not on the internet. and presence was not working on the LAN side either until I made the change in the host file.

Give it a try.