Presence-status from phones

Hi all,

I’ ve got a problem with the AsteriskIM-plug in Openfire.


  • asterisk setup (own server, hosted) tested with aprox. 15 hardwarephones

  • using Asterisk-IM 1.4 and Openfire 3.5.04 - Link with VoIP-Server works (green light)

  • using several Spark-Messenger on Windows and Ubuntu Linux 7.10


  • Actual status of hardwarephone in Spark does not work

Our VoIP-server and Openfire are running fine and with Spark (Windows) I am able to call and get calls and notifications.

(Only problem is, that I get calls/notifications not on both - hard- and softwarephone - any ideas here?! Must be a setting in


The main problem is, that the actual status of the hardwarephones (SNOM 300, 320, Linksys SPA) is not shown in Spark.

It works fine, when you have a phonecall with the software (win-version + plugin) but not with hardware.

I thought it was possible to set/see the status from phones that are connected to Asterisk?!

Did I make something wrong? What can I do to fix this?

Thank you for your help!


(VoIP-Tech @ VENTAS, IT-Dep.)

How did you setup the phone mappings in Asterisk-IM?

Thank you for your fast response!

As you can see in my attachement (deleted the other mappings for debugging):

Username: 43@voip01 (43=my hardwarephone, voip01=our jabber-/voipserver)

Device: SIP/43 (the device through asterisk-im)

Extension: 43 (my hardwarephone - is there the context from dialplan missing?!)

Caller ID: STH (my callerid internal)

Hi Sebastian,

your config is almost correct but the username is just the local part of your JID. So if your full Jabber address is then this would just be john.doe.

The extension is correct. You define the context globally (per PBX) in the “General Settings”.

Hope that helps,


So I have to set in “Extension”: 43@context ?

The context from all voip-phones, set in sip.conf?

Tried so set the username:, result is: “Error saving the service settings.”

and below Username “User does not exist”. The whole time I set user@voip01, cause it’s the server’s name, thought it was correct.

Think the rest of the complete domain hast to be set somewhere in Openfire, right?!

But where?

Thank you!


The username must be you Jabber username (the same you use when you login with Spark) WITHOUT the domain. The one you see in Opnefire’s user list at “Users/Groups” / “User Summary” in the field “Username”.

YEAH! IT works now! Thank you for your help!