Privacy List is not saved


I use Smack 3.2.1 and Openfire 3.7.0.

If I want to save Privacy List, it is not saved.

I followed the documentation here: l

But every time I want to retrieve the privacy lists, I get an empty array.

No error is thrown. Nothing. Just an empty list.

I tried it with Spark, but Spark does not save the lists either.

(see Spark Forum for related question).

Is it my Openfire, am I missing some configuration?

My Openfire DB logs say:


Do you have an idea?


My gut says it’s a Spark problem; what’s the link to your thread over on the spark forum?

It is here, but nothing is going on there:

I don’t want to believe it’s a Spark problem, because I am developing an Instant Messenger myself using Smack 3.2.1 and it doesn’t work either.

Do I need to configure something in Openfire?

I can’t explain it, but today I start my Openfire, then start Spark, go to preferences => privacy and suddenly I see about 10 privacy lists with contacts and groups. I created them last week, but they weren’t displayed then.

Then I started my Messenger and debugged and I get the lists there, too.

I am confused, but it works now…