powered by Jive Software

Problem configuring webchat

I’'ve copied the necessary files to the plugin directory, but when I attempt to access the Webchat Application I recieve the following error:

Spark Fastpath: Demo Mode

To test a workgroup request, click on the following icon(s):

Unable to connect to server using the following settings:

Server: 192.168.0.100

Port: 5222

Test Connection

Please change your server settings in the setup tool.

Hi Zeisha,

What is the doman of your server? Apparently either, 192.168.0.100 is not the server, or you have Wildfire configured on a different port.

Cheers,

Derek

My domain is hillcountryheaven.com. I’‘m not quite clear on where I would specifiy the port. I’'m currently using port 5222 for access to Spark, and I have Wildfire set up on that IP as well.

Zeisha,

Did you configure Wildfire to use that domain name (hillcountryheaven.com)? You can check this on the Server Settings page in the admin console.

Regards,

Matt

No, I configured it to use the IP address.

Zeisha,

I would recommend switching your Wildfire server configuration to use a domain name and not IP address.

Regards,

Matt

I tried doing this, was unable to launch the admin page and when starting the wildfire server would receive a series of errors. I had to subsequently edit the server name in the mysql database to regain functionality.

I’'m not sure if this helps, this is from the Wildfire server console:

Wildfire 2.5.1

Admin console listening at:

http://192.168.0.100:9090

https://192.168.0.100:9091

Spark Fastpath initialized…

Mar 29, 2006 11:27:16 AM com.jivesoftware.webchat.util.WebLog logError

WARNING: A connection to the server could not be made when attempting connection to 192.168.0.100

Message was edited by: Zeisha

Zeisha,

Another thing to check – is a firewall enabled on your computer? If so, make sure you open up the XMPP port 5222.

Regards,

Matt

Shouldn’‘t the client run on port 5222? That may be the problem. I have the client running on port 5222, but I don’'t know where to specify the port for the webchat.

Zeisha,

Yes, it will run on port 5222. You shouldn’'t need to configure this in any special way since the webchat client should always know to run on port 5222.

Any chance you could try installing on another computer? Something very strange seems to be going on with your setup.

Best Regards,

Matt

I believe I am having a similar problem. I reset the xmpp.domain to “noaa.gov” from “hostname.noaa.gov” as this will be an enterprise installation. When I try to access the web chat I get the following error:

Spark Fastpath: Demo Mode

To test a workgroup request, click on the following icon(s):

Unable to connect to server using the following settings:

Server: noaa.gov

Port: 5222

Test Connection

Please change your server settings in the setup tool.

Any ideas?

Can you connect your normal IM client to noaa.gov? If so, the web client should be able to connect as well.

Cheers,

Derek

Hi,

it may help if you enable Anonymous Login / Anyone may login to the server on page /reg-settings.jsp

LG

Hi

I’'m also having the same error and my webchat port is running in 5223. I already checked my client port in admin console and it is defined as 5222. How can i change my webchat port to 5222?? I need your help guys.

Chat Demo Mode

To test a workgroup request, click on the following icon(s):

Unable to connect to server using the following settings:

Server: solegy

Port: 5223[/b]

Test Connection

Please change your server settings in the setup tool.

Hi,

I have the same problem with this. I copied all the plugins to /plugins of WIFI. But when i navigate the Webchat webpage in the Admin Console under Spark Fastpath tab, sidebar pane under tools. See below error. My Wildfire server is running in port 9090. I need your help. thanks&Godbless.

Chat Demo Mode

To test a workgroup request, click on the following icon(s):

Unable to connect to server using the following settings:

Server: server name

Port: 5223

Test Connection

Please change your server settings in the setup tool