powered by Jive Software

Problem connecting to database on install

Hi Folks!

I’'m trying to install Wildfire 2.6.0 on my Server. JRE1.5.0 is running, and the Username/PWD to the Database is correct, but i still get errors. See here: http://www.Vegeta.at/error.log

I absolutely don’'t know, Where the Hell the error is.

P.S: It’'s Linux.

Post your wildfire.xml also, are you running any other services off of this box?

Jeff

Message was edited by: jeff_garner

any experts who can help the novice? I am very much in the forest here. I have wildfire up and running on WIN2KserverSVCPK4, it works fine, users can send and receive no problem. My situation is with LDAP and ACTIVE DIRECTORY. I want to have wildfire pull the users from active directory. I followed a thread(alastairweller and katnsteve) last week . They had a good exchange and Alastairweller resolved his problem. I tried the same thing and have had zero success. here is my file for your reveiw:)

<!adminConsole>

Message was edited by: justjeff

Just stole this link to sboggs post on how to do it for AD. make yours look like this and see what happens.

http://www.jivesoftware.org/community/thread.jspa?threadID=19119&tstart=0

Jeff

http://www.Vegeta.at/wildfire.xml

Password is edited.

Other services… Psybnc, TeamSpeak2, Apache2. But nothing in the Portrange of WF/Java.

btw: Threadhijacking sux. :[

Message was edited by: UnleashTheBeast

The “Address already in use” error message you’'re seeing means that there is already another instance of Wildfire running or some other server is bound to that port. Try killing all the Wildfire processes and then start Wildfire again.

Hope that helps,

Ryan

Theres definitely NO OTHER wildfirethread running.

And nothing on my box is running on the necessary ports.

Hi,

i wonder how you did configure Wifi if port 9090 was in use. Maybe you can shutdown Wifi again, edit the wildifre.xml adminConsole section to

delete or rename all existing log files and then start Wifi again. Then you should use admin port 9092. Maybe you can tell us when this error does occur.

LG

Okay we are making progress. when I started wildfire it went all the way to line39 before it ERRORed out. I checked line 39 and it is actually 12th up from the bottom. writing configs and xml stuff…it’'s a mystery to me.

<![CDATA[ (& (objectCategory=Group) (objectClass=group) (memberOf=cn=Wildfire,cn=Users,dc=company,dc=com) (member=)

)

]]>

okay we are making progress. when i made the changes you suggested wildfire was able to make it all the way to line39 before ERRORing out. What’’ Next?

<![CDATA[ (& (objectCategory=Group) (objectClass=group) (memberOf=cn=Wildfire,cn=Users,dc=company,dc=com) (member=)

)

]]>

Ok. in your admin DN, why do you have invpro/wildfire. why not just wildfire unless it is in another location and if so, just specify it as cn=wildfire,ou=invpro,dc-company,dc=com… that is just sort fo throwing me off. sorry. I have no idea what line 39 means. can you either post your error logs or tell me what error you are getting now.

Thanks,

Jeff

Message was edited by: jeff_garner

jeff;

I fllowed your steps, ran it and still receive error on line 39. you asked for the error data so here it is.

error 11448 () ; error reading the XML properties

org.dom4j.documentException: Error on line 39 of document : the makeup in the document following the rrot element must be well-formed.

nested exception; the markup of the document following the root must be well-formed

at org.dom4j.io.saxreader.java:482

so forth and so on!

Man I wished I knew what line 39 was… Ok, the error is saying that an expression in XML is not well formed. Question, have you attempted to comment out your search filters? Just as a test to exclude these as a point of failure. Try that and then restart the server. THis might open the database up for the search, but it might point us to the root of the problem…

Jeff

I am back!, sorry I took so long getting back. you know…priorities!

I tried the blocking of those search line(s) or at least I thought i did. I put a % symbol in front of those lines. and I had the same result. Man oh man I am TORGUED!@#$%^&*(

certainly not you! I am just pissed at this config file.

any insights?

Thanks;

Jeff