powered by Jive Software

Problem with Openfire Login

OPENFIRE 3.6.4

SuSE LINUX

MySQL 5

Im having problens with openfire login.

Look what I have done.

First, installed openfire.

Then I tried to login with my openfire admin account and i got error of username/password invalid or im not admin.

After some restarts and reinstalls i logged and started using… I was very happy…

Then i needed to change the JVM memory. When I restarted the service all stopped again.

I tried restart service, reinstall a lot of times and nothing.

Then I saw something at logs ( info.log ).

when I start the service there appears a line “User Login Failed. PLAIN authentication failed”.

Any idea what is this? and how to make it work?

I Just reinstalled everything from 0 except the database and worked and i was still with the data… so its ok now… maybe some bug.

So, i was too late

After the installation you **have **to restart the Openfire. It won’t let you to login until you restart. It says you can login, but it doesnt work, it’s a known bug. So, you have to restart.

That info log doesnt say much. Next time you should also check errors log.

What worked for me was to shut down openfire, shut down apache, shut down mysql (in that order) and then restart them in the reverse order.

Also, the openfire set-up asks for an admin account user name in the form of an email address such as admin@example.com. However, when you want to login, just use admin as the user name (leave out @example.com).

SameerJ wrote:

Also, the openfire set-up asks for an admin account user name in the form of an email address such as admin@example.com.

This setup page says “Enter settings for the system administrator account (username of “admin”) below.” And this field is named “Admin Email Address:”. So, it is not an admin acount it asks for. Default admin account is always “admin”.

OK, I see - the user name of the administrator remains “admin” irrespective of the email address entered. It was somewhat confusing for me. Perhaps it would be helpful to make the wording more explicit, such as: “An administrator account will be created for which the username will be “admin”. Enter here the desired password and give the email address of the administrator.”

Thanks for all the good work.

Regards.

Restarting didn’t work for me. The only thing after working with it for a while was setting the encryptedPassword field to null in the database and setting plainPassword to my password. Ignite, you have a bug with your encryptedPassword field. Other than that, it all seems great. Thanks.

jacwright wrote:

Ignite, you have a bug with your encryptedPassword field.

What’s the way to reproduce it?

I set up openfire using the latest stable .deb binary on Ubuntu with the latest stable MySQL 5 server. I tried several passwords since the first one had a “#” in it and I wanted to ensure that didn’t break it. I couldn’t get it to work without modifying the database directly, so I’m not sure how to not reproduce it. This was the first OpenFire server I set up.

Other things that may play into it:

The database is using UTF8 encoding.

MySQL version is 5.0.51

I tried logging in using the HTTP and HTTPS with no success. Tried shutting down mysql and openfire then starting them up in that order. Tried patting my head and rubbing my tummy while pressing Log In (I was surprised that one didn’t work). Tried an alpha-numeric only password with no special characters. Cleared out the database completely (dropped all tables) and tried it again.

I wonder if you can test with the SVN version, or maybe we should wait for 3.6.5 and then test that again. I dont know is it UTF or MySQL, but it usually works fine with the embedded-db for me.

Hello,

I’m having the same issue on ubunutu. I’ve set the encryptedPassword to NULL and used the password in plainPassword field but it still won’t let me in the admin console. Interestingly, I could login to openfire via the spark client, but couldn’t via the web admin portion.

Any suggestions, perhaps I should downgrade to an earlier versions?

Ok, after 3 installs and playing around with the database I was able to get it to work…sort of. I can now log into the web admin console but, i can no longer create accounts or connect via the spark client…