powered by Jive Software

Problem with pymsnt jid

hi there…

i have a problem regarding msn jid. i’‘m using pymsnt. but i don’'t want to show the jid e.g “friend%hotmail.com@msn.host.com”. can it be just “friend” like in jid yahoo transport? can anyone plz help me

mohd_izzuan

In my humble opinion, I think that it is not wildfire issue. It is pymsnt issue itself. I have tested pymsnt and pyaimt. pyaimt does not show like the way pymsnt does in psi client. So I think you need to contact pymsnt developer. By the way which yahoo transport are you running? Just interested.

Regards,

wmhtet

Yes, contact pymsn-t developer:

http://msn-transport.jabberstudio.org/?page=contact

wmhtet

u can download yahoo-transport at http://www.jivesoftware.org/community/thread.jspa?threadID=15695&tstart=0

again, about the pymsnt jid. can wildfire filter the long jid? and just plain username@hotmail.com.

problem solved. all i need is to change on the jabber client. thanks guys…

cool!

But it would be much better if you can provide the information on how you solve it. In your case, you found the solution in the client. There are a lot of jabber client out there and if you tell us which client has solved your need, it will help next person with your needs when he read this thread.

Regards,

wmhtet

I have looked at psi pandion spark exodus and I don’'t find the option or setting for that but I have to admit that I have been looking for that on jabber server without transport at all!!! I will look at them with the server that has transport. Duh!!! What a simple solution!!! Just rename the complex contact name(***%hotmail.com@msn.wildfire.mydomain.com) to the simpler contact name (hotmailFriend). That is using psi. I forgot to check with other clients. I am fool enough to chat oneself using multiple clients with multiple protocols .

Regards,

wmhtet

on the client side you have to change in the coding of the contact list. i’‘m using java. here’'s how i filter the jid…

return fullJid.substring(0,fullJid.indexOf(’’%’’));