powered by Jive Software

Problem with S2s to swissjabber.org

Hello!

Ever since I updated to 3.6(a) i have problems communicationg with S2S to swissjabber.org.

They have a nice bot sitting at woerterbuch.info@swissjabber.org which is a english/german dictionary.

When I open a chat window to this “user” most of the time it works but there is no online status being delivered to the spark clients.

Maybe it is at their site but it looks like perfect communication went away with 3.6

Can anybody confirm ?

Bye

Starry

Hi

whats the setting for s2s security? It should be Optional. What’s in the debug log during the connection attempt to woerterbuch.info@swissjabber.org

Kind regrads,

Walter

Hello!

S2S Security is set to optional, however the " Accept self-signed certificates" checkbox is NOT checked! Could this be a source of the problem?

Bye

Starry

Hello!

2008.10.21 22:48:34 [org.jivesoftware.openfire.net.SocketReadingMode.negotiateTLS(SocketReadingMode .java:77)] Error while negotiating TLS: org.jivesoftware.openfire.net.SocketConnection@1b11c0b socket: Socket[addr=/217.150.254.106,port=41729,localport=5269] session: org.jivesoftware.openfire.session.LocalIncomingServerSession@1f299f5 status: 1 address: proxy.mocom.at/1fc2e957 id: 1fc2e957
javax.net.ssl.SSLProtocolException: Data received in non-data state: 1
at com.sun.net.ssl.internal.ssl.SSLEngineImpl.readRecord(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLEngineImpl.readNetRecord(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLEngineImpl.unwrap(Unknown Source)
at javax.net.ssl.SSLEngine.unwrap(Unknown Source)
at org.jivesoftware.openfire.net.TLSStreamHandler.doHandshake(TLSStreamHandler.jav a:214)
at org.jivesoftware.openfire.net.TLSStreamHandler.start(TLSStreamHandler.java:160)
at org.jivesoftware.openfire.net.SocketConnection.startTLS(SocketConnection.java:1 69)
at org.jivesoftware.openfire.net.SocketReadingMode.negotiateTLS(SocketReadingMode. java:74)
at org.jivesoftware.openfire.net.BlockingReadingMode.readStream(BlockingReadingMod e.java:127)
at org.jivesoftware.openfire.net.BlockingReadingMode.run(BlockingReadingMode.java: 63)
at org.jivesoftware.openfire.net.SocketReader.run(SocketReader.java:120)
at java.lang.Thread.run(Unknown Source)

So, it looks like you are right but what to do? Enable this checkbox? Installing a local copy of their certificate so it is known or trusted?

Bye

Starry

Ping!

Any takers?

Hello!

I enabled “accept self-signed certificates” which is also shown in warn.log

2009.01.25 16:44:52 Accepting self-signed certificate of remote server: [swissjabber.org]

but it still doesn not like to connect…

In Error.log I find the following:

2009.01.25 16:53:29 [org.jivesoftware.openfire.net.SocketReadingMode.negotiateTLS(SocketReadingMode .java:77)] Error while negotiating TLS: org.jivesoftware.openfire.net.SocketConnection@8864af socket: Socket[addr=/217.150.254.106,port=48505,localport=5269] session: org.jivesoftware.openfire.session.LocalIncomingServerSession@1d74bb1 status: 1 address: proxy.mocom.at/6bec41a3 id: 6bec41a3
javax.net.ssl.SSLProtocolException: Data received in non-data state: 1
at com.sun.net.ssl.internal.ssl.SSLEngineImpl.readRecord(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLEngineImpl.readNetRecord(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLEngineImpl.unwrap(Unknown Source)
at javax.net.ssl.SSLEngine.unwrap(Unknown Source)
at org.jivesoftware.openfire.net.TLSStreamHandler.doHandshake(TLSStreamHandler.jav a:214)
at org.jivesoftware.openfire.net.TLSStreamHandler.start(TLSStreamHandler.java:160)
at org.jivesoftware.openfire.net.SocketConnection.startTLS(SocketConnection.java:1 69)
at org.jivesoftware.openfire.net.SocketReadingMode.negotiateTLS(SocketReadingMode. java:74)
at org.jivesoftware.openfire.net.BlockingReadingMode.readStream(BlockingReadingMod e.java:127)
at org.jivesoftware.openfire.net.BlockingReadingMode.run(BlockingReadingMode.java: 63)
at org.jivesoftware.openfire.net.SocketReader.run(SocketReader.java:120)
at java.lang.Thread.run(Unknown Source)

So, it looks that my side accepts the self-signed cert but swissjabber does not, right?

Is there anything I can check on my side? I never even touched the certificate setup, I guess it got installed when I installed openfire…

I would be glad, if somebody could point me into the right direction, thanks in advance!

Starry