powered by Jive Software

Problem with Spark and Folder Redirection in Windows

Hi,

When you have Folder Redirection enabled on Active Directory for example my Desktop, i can’‘t connect Spark to Wildfire. I mean: Wildfire see my connection request but Spark can’'t load, it stay on Authenticating. If i disable Folder Redirection, the problem disapear and Spark connect without problem. There is no other policy setting, only the folder redirection of Desktop. Anyone have an idea for this? Thanks!

I’‘m using redirected folders on both Desktop and My Documents. Although it sometimes takes awhile to login, I can login as long as i’'m not in Offline mode.

One thing that makes a difference for me is using pskill to terminate Spark when it hangs. pskill is a free windows utility from sysinternals (http://www.sysinternals.com/Utilities/PsKill.html). Here’'s what I did.

Download pskill, and copy it to C:\Windows\system32

Write a batch file called spark.bat, saved in c:\documents and settings\ralphh\spark.bat.

Batch file looks like this:

pskill spark.exe

“c:\program files\spark\spark.exe”

Put shortcut on desktop

Now, when I double click it, it terminates any running instance of Spark and then relaunches it. This is very useful when I bring my notebook back into the office and I’'m in offline mode. Spark hangs, then I double click that to re-login.

Hope this workaround helps somebody.

ralphhogaboom

If Offline Mode is enable you cannot log In? Thanks!

Take a look at what I posted here: http://www.igniterealtime.org/community/thread/29048

I think we have similiar issues. Is this the registry key your setting to do the redirection? HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Desktop

I have issues with spark and folder redirection as well. When im in our office and connected to our domain server where the desktop and my documents folders redirect to, all is well. When i am away and working in “offline mode”, my spark settings are gone (it can’t get the spark.properties file) and spark doesn’t want to login, sits there “authenticating”.

Anyone find a workaround? This may be a bug I guess?

That is the same outcome we have if spark does not have permissions to create the files in the default location. Hopefully Derek will figure out a fix of some sort (or at least a work around).