powered by Jive Software

Problems installing on FC3

Hi, I am trying to installin Jive Messenger on Fedora Core 3. Ran the rpm with no issues and am able to start messenger. Where I am having issues is in running the redhat-postinstall script. When I run it I get either bad interpreter errors or No such file or directory errors depending on how I run it. I have run chmod 755 on the file and am logged on as root. What could be the issue? Does anyone have a good step by step instruction for FC3? Any help would be greatly appreciated.

Thanks!

No love on this?

MaldiGola,

I apologize for the late reply. This might be a problem with Windows vs Linux linefeeds. I think we fixed that problem for the upcoming 2.1.2 release.

Regards,

Matt

I downloaded and installed the newest rpm today. When I run redhat-postinstall.sh I get the following errors:

./redhat-postinstall.sh

cp: cannot stat `/opt/jive_messsenger/bin/extra/jive-messengerd’’: No such file or directory

service jive-messengerd does not support chkconfig

service jive-messengerd does not support chkconfig

/bin/chown: cannot access `/opt/jive_messsenger’’: No such file or directory

Any clues?

Yeah, run dos2unix on that file, and you will be all set. I run into this all the time on shell scripts copied from windows to linux machines. Not sure how your file got that way, but dos2unix will fix you up.

I also noticed back in 2.1.1 version there was a typo in the jive-messengerd script file with the chkconfig line.

If your having the problems running the redhat-postinstall script, you probably need to run them on the jive-messengerd file as well. And I suspect it might not hurt on the bin/messenger file since that is a script as well.

Message was edited by:

ewbragg

Ran dos2unix against those 2 files and I still receive the same errors.

The problem is that one line has 3 “s” in messenger. Just edit the file and remove the extra s.

Here’'s a diff for the developers. This script should probably have execute permission.

redhat-postinstall.sh 2005-03-07 00:12:13.000000000 -0700

+++ redhat-postinstall.sh.new 2005-03-11 09:52:24.000000000 -0700

@@ -17,7 +17,7 @@

if ; then

if [ -d “/opt/jive_messenger” ]; then

  •           MESSENGER_HOME="/opt/jive_messsenger"
    
  •           MESSENGER_HOME="/opt/jive_messenger"
    

elif [ -d “/usr/local/jive_messenger” ]; then

MESSENGER_HOME="/usr/local/jive_messenger"

fi

Thanks Dave for the bug report. The problem has been fixed for the next release.

Thanks,

– Gato

That worked! Thanks everyone!