powered by Jive Software

Problems installing on Win2000

I’'m trying to install Jive messenger 2.2 on Win2000 Sp4, (JDK 1.4.2 installed and exstensively used, i work with it through VNC ) however installer stops working after displaying progress bar and “preparing to install” message (it (apparently) does not do anything, but responds to cancel button. ) Exsactly the same install file works fine on two other machines. What could it be?

install log:

Started executable C:\JIVESTUFF\jive_messenger_2_2_2.exe at Sun Sep 25 18:53:22 2005

Init

Init done

Starting work

extracting files

Included files: 8

Temp dir: C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\i4jruntime.jar (size: 322405)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\content.zip.lzma (size: 6802361)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\i4jparams.conf (size: 132851)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\jre.tar.gz (size: 12289566)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\License (size: 18698)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\MessagesDefault (size: 18557)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\platform.zip (size: 166968)

extracting C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\stats.properties (size: 111)

extracting files done

Current working dir: C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028

Full JRE path: C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\jre.tar.gz

JRE included

extracting JRE

untaring JRE was successful

JRE is packed

Unpacking JRE

Unpacking jre\lib\rt.jar.pack to jre\lib\rt.jar

waiting for unpack200 to finish

unpack done

Unpacking jre\lib\charsets.jar.pack to jre\lib\charsets.jar

waiting for unpack200 to finish

unpack done

Unpacking jre\lib\plugin.jar.pack to jre\lib\plugin.jar

waiting for unpack200 to finish

unpack done

Unpacking jre\lib\deploy.jar.pack to jre\lib\deploy.jar

waiting for unpack200 to finish

unpack done

Unpacking jre\lib\ext\localedata.jar.pack to jre\lib\ext\localedata.jar

waiting for unpack200 to finish

unpack done

Unpacking jre\lib\jsse.jar.pack to jre\lib\jsse.jar

waiting for unpack200 to finish

unpack done

Unpacking JRE done

JRE dir: C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\jre

LoadDLL (0, C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\jre, 0)

Got JRE location C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028\jre (java exe: 0)

MinVersion: 1.5, MaxVersion:

Trying to load JVM-DLL from c:\docume1\admini1\locals~1\temp\e4j2ba.tmp_dir7028\jre\bin\java.exe

Trying c:\docume1\admini1\locals~1\temp\e4j2ba.tmp_dir7028\jre\bin\hotspot\jvm.dll (exists 0)

Trying c:\docume1\admini1\locals~1\temp\e4j2ba.tmp_dir7028\jre\bin\client\jvm.dll (exists 1)

Loading of JVM-DLL successful

launching program

vmoption count 7

vmoption 0: -Dexe4j.semaphoreName=c:_jivest1_jive_m1.exe

vmoption 1: -Dexe4j.isInstall4j=true

vmoption 2: -Dexe4j.moduleName=c:\jivest1\jive_m1.exe

vmoption 3: -Dexe4j.processCommFile=C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j_p3432.tmp

vmoption 4: -Dexe4j.tempDir=C:\DOCUME1\ADMINI1\LOCALS~1\Temp\e4j2BA.tmp_dir7028

vmoption 5: -Djava.class.path=C:\DOCUME1\ADMINI1\LOCALS1\Temp\e4j2BA.tmp_dir7028\i4jruntime.jar;C:\DOCUME1\ADMINI1\LOCALS1\Temp\e4j2BA.tmp_dir7028\platform.zip;

vmoption 6: -Dsun.java2d.noddraw=true

Creating JVM

JVM created

main class: com/exe4j/runtime/WinLauncher

param count: 6

param 0: false

param 1: com.install4j.runtime.installer.Installer

param 2: c:\jivest~1\error.log

param 3:

param 4: false

param 5: C:\JIVESTUFF\jive_messenger_2_2_2.exe

calling main

main returned

dest JVM

Ok, I unpacked UNIX installation and copied startup files from the windows test install. Didn’'t work! Now it keeps to not to see JRE ten other java programs have no problem finding. I set EXE4J_JAVA_HOME variable to point to JDK, i verified this with set command - there is that variable and it points to valid JDK. nothhing works.

I solved the problem (sort of) I installed JDK 1.5 (seems that it is required.) and crearted batchfile to run startup class, but I’'d still be interestet if there is a way to install JM properly.

you are mentioning JDK, but you need to have a JRE. Well, i have only JRE 1.5.0-05 installed.

Yes I know… But There are many apps on that server requiring full JDK, and although I didn’'t upgrade them, I decided that having full JDK is a good idea anyway.

Hi,

I have had the same problem for months

Installation starts and then hangs on “preparing to install”.

Now i have found the problem. It was cygwin1.dll

If i click on cancel button installation quit, but cpu use remains high.

Task manager show that cpu is used by cygunsrv.exe (and this happens only after Jive Messenger installation).

I must kill it to obtain low cpu use.

Now i have tried to stop rsync deamon (the application that uses cygwin1.dll), i have killed all instance of cygunsrv.exe and rsync.exe and i have retried to install Jive Messenger.

It works, installation done without problems