Problems to start the openfire ( urgent)

Good … I have openfire installed on a server with linux (debian) 7 and the day yesterday some funny turn off the server and did not want me to lift the service worked perfectly normal check the error log to see what I can do and I get the following

2016.03.29 10:27:40 org.jivesoftware.openfire.XMPPServer - java.sql.SQLException: ConnectionManager.getConnection() failed to obtain a connection aft$

java.lang.IllegalArgumentException: java.sql.SQLException: ConnectionManager.getConnection() failed to obtain a connection after 11 retries. The exce$

at org.jivesoftware.openfire.XMPPServer.verifyDataSource(

at org.jivesoftware.openfire.XMPPServer.start(

at org.jivesoftware.openfire.XMPPServer.(

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessor

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructor

at java.lang.reflect.Constructor.newInstance(

at java.lang.Class.newInstance(

at org.jivesoftware.openfire.starter.ServerStarter.start(

at org.jivesoftware.openfire.starter.ServerStarter.main(

Caused by: java.sql.SQLException: ConnectionManager.getConnection() failed to obtain a connection after 11 retries. The exception from the last attem$

at org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManager .java:156)

at org.jivesoftware.openfire.XMPPServer.verifyDataSource(

… 9 more

I hope you can help me solve this problem. it is noteworthy that do not use any special setting, only simple installation and use the same database that gives me the openfire.

Stop/Kill openfire and make a backup of conf/openfire.xml. Then edit con/openfire.xml and make sure that the connection string is valid. If the username and password are encrypted try to replace them with unencrypted values.

Check the file located in /usr/share/openfire/conf/openfire.xml and I get the following

<? Xml version = "1.0" encoding = "UTF-8"?>

<! -

This file stores bootstrap properties needed by Openfire.

Property names must be in the format: “ = value”

That will be stored as:

value </ blah>

</ Is>

</ Name>

</ Prop>

Most properties are stored in the Openfire database. TO

property viewer and editor is included in the admin console.


<! - Root element, all properties must be under esta element ->

<! - Disable Either port by setting the value to -1 ->

9090 </ port>

9091 </ SecurePort>

</ Adminconsole>

is </ locale>

<! - Network settings. By default, Openfire will bind to all network interfaces.

Alternatively, you can specify a specific network interfaces That the server

will listen on. For example, This setting is useful only Generally

on multi-homed servers. -> </ interface>

</ Network>

<! - SPDY Protocol is npn.

(Note: does not work npn With Java 8)

add -Xbootclasspath / p: /OPENFIRE_HOME/lib/npn-boot.jar to .vmoptions file ->

<! -

npn </ protocol>

</ SPDY>

not where it should change the connection string or affix the openfire was admin user and password 201601012016

I thank you in advance for the help

This file is not complete. It’s interesting that Openfire starts without showing you the setup option. I wonder whether this is the right file.

You may want to use a zip tool to extract a complete openfire.xml file and replace the existing one. Then starting Openfire should allow you to run the configuration wizard again.

that route I look for the file openfire.xml look for it on the following routes:



and both have the same settings that you place in the comment above, I’m using debian 7 do not know if that file should look for another route.

thank you very much for the support you are giving me.