Problems with BOSH


I am trying to configure BOSH but have not been able to. I have tried some of the examples included with the Strophe XMPP Client JavaScript library, but I never have been able to connect successfully. When I try to connect, I get a not-authorized failure. I am using http://localhost:7070/http-bind/ to connect.

I also noticed that when I visit the url http://localhost:7070/http-bind/ in the browser, I get a 400 bad request error, even though I have enabled 7070 and 7443 BOSH ports and enabled script access in the Openfire admin panel.

Is there something I am doing wrong here? Has anyone else had this problem?

Hi there,

to use Openfire with Bosh you need:

1.) 3.7 Beta of Openfire

2.) Go to “Server Settings” > “HTTP Binding” and enable all

That’s all to do in Openfire.

Is localhost realy the name of your openfire server ?
(If not shure have a look in System Server > System Properties xmpp.domain

Probably you need to set the hostname in your application.

Try localhost:7070/http-bind/ without the http://

If this still doesn’t work try to deactivate your firewall and the one on the server to test it.

I wrote a XMPP app and things work correct

except problems with the not existing automatic disconnect on server side if session is down on.

Good luck