powered by Jive Software

Problems with connecting to Yahoo

We are having lots of issues with Yahoo this morning. Users are getting bounced out and we need to recycle them several times to get them back in. Is anyone having similar problems?

Using Yahoo Messenger directly doesn’t seem to have any issues.



Same here, cannot connect? Its also failing on the tests from the server.

I’d like to pipe in with a “me too”. Started over the weekend, and now all my users are unable to connect to Yahoo, and the test fails.

Well, restarting the IM Gateway plugin worked this time. Now everyone is connected.

This is the second time that I have experienced this issue in the last 6 weeks. The first time it happened I tried everything I could think of to correct the problem and nothing worked; however 48 hours after the problem started it disappeared just as quickly. I have been testing with standalone yahoo clients and other integrated clinets and have been experiencing mixed results. Some will connect and some will not currently. My guess is that this is something on yahoo’s side that is causing this. I have not han any issues with ANY of the other integrated IM Gateways.

We started to have this very same issue over this week-end. ( 4/18 - 4/20). Did Yahoo change their protocol?

I don’t think that it is a protocol issue. Our thoughts are some of their servers are having problems and their load balancer is still sending connection requests to those servers. If we try reconnecting enough times then everything is fine.

Which make sense. Since all we do is try few times later and it works, but it this was never the case before this week-end. So hopefully, it is a yahoo load balancer issue and yahoo put their act together and fix it soon…


I assume you mean restarting the IM Gateway when you say you try reconnecting several times. Is that correct? I’d like to be better prepared when this starts happening again. Trying to re-connect with the client seems to do no good.

Over the weekend, I restarted it a couple times, to no avail. I didn’t keep trying after that. I did set the reconnection attempts to 8, which also didn’t seem to fix the problem. Restarting it this morning seemed to do the trick, but I don’t know if that’s because the problem was fixed, or if I got lucky.

I just switched to OpenFire last week, and while it’s a lot easier to manage than the jabberd2 I was using before, I’ve never had this kind of trouble with my old yahoo transport. Is there something that can be changed in the IM Gateway to make it more robust in this respect? If other transports and direct Yahoo clients can manage, I’d say it’s a bug in the IM Gateway if it can’t connect.

Well, restarting the gateway sometime fix it some time it doesn’t. As if it depends, where you connect on which yahoo server, if the issue is the load balancer that is. On a side note, what I realize is that if I test the yahoo messanger under gateway settings, sometime I get success and some time I get failed, while If I test MSN messanger or AIM messanger it always a success and again this is only a behavior I started noticing over the week-end. This was never an issue before…


I just tried the test button on my server, and it was failing. I tried many times in a row. So I tried this command to test the connection in a more direct manner:

“telnet scs.msg.yahoo.com 5050”

The result was this:

Connected to scs.msg.yahoo.com.

It succeeded on the 11th try. My retry count in openfire was set to 10 at the time. Cranked it up to 20, and the test succeeded. It’s only anectodal, but it’s worth a shot. It might be excessive, though. Looks like yahoo only has 18 servers balanced under “scs.msg.yahoo.com”.


Nevermind. I just got a failure again.

Message was edited by: trebonius

that is a good idea. I will try that as well…thanks for sharing it…

are you setting the “Reconnect on Disconnect” attempts or is there another setting to try?

“Reconnect on Disconnect”. This is the only place I know of to change the number of attempts per transporter

Yes. I don’t know yet if it’s a complete fix.

My organization also seems to be affected by this. I have attempted to restart the IM Gateway plugin (a few times now), and then I read the post about increasing the retry count to a value higher than 10. Now, when I go to the Gateways section in Openfire’s web console, I receive the following error:


java.lang.ClassCastException: org.jivesoftware.openfire.gateway.GatewayPlugin cannot be cast to org.jivesoftware.openfire.gateway.GatewayPlugin
     at org.jivesoftware.openfire.plugin.gateway.gateway_002dsettings_jsp._jspService(gateway_002dsettings_jsp.java:68)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
     at org.jivesoftware.openfire.container.PluginServlet.handleJSP(PluginServlet.java:229)
     at org.jivesoftware.openfire.container.PluginServlet.service(PluginServlet.java:87)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
     at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
     at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
     at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:42)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
     at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
     at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
     at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
     at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
     at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
     at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
     at org.mortbay.jetty.Server.handle(Server.java:324)
     at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
     at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
     at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
     at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
     at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
     at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
     at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Any ideas?

I am getting the same error. Restart the openfire services to restart the gateway plugin.

Try a different yahoo server in the gateway settings - I changed mine and it connected up without any problems.


http://help.yahoo.com/l/us/yahoo/messenger/messenger75/messenger/messenger-02.ht ml

EDIT: Oh and if you haven’t updated the Gateway to Kraken, you might want to try that too. http://kraken.blathersource.org/

I got the same problem.

Luckily I was able to find a different Yahoo server that I could connect to before I messed the plugin up. I guess that’s what I get for not reading everything and just looking at the last post.

Anyone have any ideas on how to fix this without reinstalling the plugin?

This seems to be happening at random independent of plugin version.