powered by Jive Software

Problems with file transfer between Spark 2.8.1 & 2.7.x

Hi folks,

it seems that there is a problem between different Spark versions while trying to transfer files (screens etc.).

Sending a screen from spark version 2.7.1 to spark 2.8.1 doesn´t work. it always gives an error.

Transfer between 2.7.x clients works like a charm!

Any clue why this happens? Someone out there facing the same problems?

cheers, Lars

So far it looks like file transfer is not working in 2.8.x. It seems to me i was testing it with 2.8 not so long ago, but i’m not sure it wasn’t before 2.8.0 actually. Will test tomorrow at work (in a real network, as i can only test between VMs here). That might be another victim of Smack library update to the latest version…

thanks a lot! would help to know if it all comes from updated Smack library! Hopefully the transfer function can be fixed then…

So far with my tests with virtual machines i was able to send files from 2.8 to 2.8 from a virtual machine to a host (WinXp/Win7 to Win7), but not vice verca. 2.7 works in almost every scenario. Also it seems it was working on Ubuntu/Xubuntu a month ago based on my comment on this ticket [SPARK-1698] Can’t open received file on Ubuntu - IgniteRealtime JIRA but now it doesn’t. It worked with 16.04 Ubuntu version, now i use 16.10 (there were problems with 15.10 before). Looks like non LTS versions of Ubuntu have some problems, eh. Anyway, file transfer works in some cases, but it is not as reliable as in 2.7 version. Will test more today.

Also, this might be related [SPARK-1793] File transfer fails when switching to SOCKS5 - IgniteRealtime JIRA

So, i have tried between 2.8.2 versions and between 2.8.2 and 2.7.7 at work. Works fine. We have File Proxy disabled at work in Admin Console. Although at home that setting didn’t make any difference. All systems are Win7 Pro here.