Problems with HTTP Binding in 3.5.1?

I’m stumped on this issue, so I thought I’d turn to the forums to see if anyone had any idea. I’ve been trying to get SparkWeb working via HTTP Binding, but it seems that OpenFire doesn’t want that to happen. I have my HTTP Binding ports set to 8080 and 8443, but when I go to http://mydomain:8080/http-bind/, I get an error with Jetty giving me a 404, saying /http-bind/ is not found. It’s the same thing regardless of what directory I try, and even if I don’t specify a directory (it’ll just say it can’t find /). Am I missing some configuration option? Obviously SparkWeb doesn’t work, since I can’t figure out where OpenFire’s HTTP Binding directory is supposed to be. Thanks!


Bump to keep this alive. Or, perhaps I can rephrase the question. Is there anyone out there who is using HTTP Binding with 3.5.1? If so, what are your settings, and what URL do you use to access the HTTP Binding functionality?


check the forum i’ve posted some valid configs for this escenario in an old thread. don’t have the link right here, sorry.

but i can tell you that is working right now.

I haven’t been able to find the configurations you’ve mentioned, and Clearspace doesn’t seem to let me search for posts you’ve made, only discussions you’ve started.

Anyway, obviously HTTP Binding is enabled or OpenFire wouldn’t be listening on that port. I’ve seen many threads with similar problems, but few (if any) answers from anyone involved with OpenFire development. So, I’m stuck. I want to roll out an option that can use SparkWeb or JWChat via HTTP Binding, but right now, that’s just not going to happen because this stuff doesn’t seem to work.

If there are settings other than the “Enabled/Disabled” toggle in the admin console, well, someone needs to document that somewhere. At present I’m also not doing anything with Tomcat, proxying, etc. It’s just straight HTTP to the server on the HTTP Binding port.