Problems with LDAP


I have installed Wildfire on small business server 2003, without any problems, and was working with generic passwords.

I have been attempting to have the system using our Active Directory - however, it does not seem to be playing ball, and the logs are not generating any errors, so I’‘m not sure what’'s going on!

My configuration file has been altered to read:

<ldap>     <host>localhost</host>      <port>389</port>      <usernameField>sAMAccountName</usernameField>      <nameField>displayName</nameField>      <emailField>mail</emailField>      <baseDN>OU=MyBusiness,DC=bsb,DC=local</baseDN>      <adminDN/>      <adminPassword/>   </ldap>  and the <admin> section has been altered to include:     <authorizedUsernames>DApthorpe</authorizedUsernames>  Any advice much appreciated! Thanks in advance, David

Did you remove the comment tags from around the LDAP section? (by default there is a after the ldap section, therefore commenting the whole lot out… This sometimes get missed)

Also, did you add the LDAP providers?



I have removed the

Discovered this error in the debug section when attempting to log in - not sure if this is helpful or not.

Thanks very much - David

2006.08.18 12:04:03 Exception thrown when searching for userDN based on username ‘‘dapthorpe’’

javax.naming.AuthenticationException: LDAP: error code 49 - 80090308: LdapErr: DSID-0C090334, comment: AcceptSecurityContext error, data 525, vece

at com.sun.jndi.ldap.LdapCtx.mapErrorCode(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.processReturnCode(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.processReturnCode(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.connect(Unknown Source)

at com.sun.jndi.ldap.LdapCtx.(Unknown Source)

at org.jivesoftware.wildfire.ldap.LdapManager.getContext(

at org.jivesoftware.wildfire.ldap.LdapManager.findUserDN(

at org.jivesoftware.wildfire.ldap.LdapManager.findUserDN(

at org.jivesoftware.wildfire.ldap.LdapAuthProvider.authenticate(LdapAuthProvider.j ava:90)

at org.jivesoftware.wildfire.auth.AuthFactory.authenticate(


at :172)



at 62)


at Source)

Solved this problem… partly. I can now log on using Spark, but not to the Admin section. I have added but that still doesn’'t allow Administrative log in, yet logging into Spark does.

Any suggestions?

Solved. The authorised user has to be lower case. Quite strange!

Hi i am also setting this up on an SBS 2003 server and just wanted to ask if you could let me know what your final solution was? thanks in advance



current setup is like this:

Currently I can’'t get either filter to work… just stops me logging in. Will keep working on this after the bank holiday though!!!