powered by Jive Software

Problems with RED5Phone

Hey!! well im having some problems with the red5phone connecting to Asterisk. A possible mistake is also the RED5 URL… which for the red5phone should be rtmp:/sip but by some reason is not connecting but if i put rtmp:/oflaDemo it says “connection sussesful” but nothing happens after… Deje already told me that “oflaDemo” is not what it is for red5phone but “rtmp:/sip” i try by changing the path but still same error… please anyone intrested on helping please answer… ill give the url of the server… my be someone can check it out… and give me a hand… thanks!

zip up all your log files in logs folder and post here and someone can take a look and offer advice.

Well, i think that i am really doing something wrong… becaus my red5 is not generating logs! although the sip.cfg is well set. as in the red5HOME there are not stored any passwords or nothing. i ask if someone can tar and send me a link of the red5home, you have working for me to download and test because either something with the ant compilation or de red5 server must be wrong. i really appreciate all ur help!!!

peace.

I had similar problem like Gaston had. I tried to login in the Red5 Phone Test page using red5 url rtmp:/sip. I’m getting the message as Connection Success. After some time i’m getting the Registration time out message. can any one help on this issue. what r the changes required to login.

it is hard to help you with the details you give

connection success indicate that the flash object is connected to the red5 and reg time out indicate that red5 did not get any replay from your proxy.

can you tell what have you put in your red5 phone flash (domain,realm,red5 url…)?

is your red5server is same as your Proxy server/Asterisk ?

as far as i know from others user it work now both on Linux and Windows.

Lior

Hi,

I had given details same as it is as in sip.conf file of asterisk.

i.e

Domain name: 192.168.2.32(which was my ip)

Realm server: 192.168.2.32

username:3007( which was included in sip.conf of asterisk server)

password:xxxx

red5 url: rtmp:/sip.

and i tried with different proportionalities as giving red5 url as

rtmp://192.168.2.32:8080/sip

rtmpt://192.168.2.32:8000/sip(cause that i deployed through the openfire).

I had another issue. I retried the web based sip application with out using openfire. i.e by using standalone Red5 server.

It was totally out of reach as it was not working in linux.

Hi

look like to me your red5 plugin do not send REGISTRATION.

please check the followings:

use rtmp://<red 5 ip>/sip (without port 8000).

try take traces on you proxy/asterisk to see if red5 send REG message.

try look on red5 logs for errors and sip messages.

Lior