powered by Jive Software

Problems with voice call

Good morning guys.

I’'ve some troubles with voice call on Spark IM. When i do a call Spark get me a message seemed “voice chat ended: no media received. This may because by firewall configuration problem”.

Where i configure these settings in Openfire?

PS.: Sorry by my english!

Ever get any help with this? We’‘re having the same problem. We’‘re just running it on a LAN…server and all clients inside the firewall. Voice doesn’‘t work, we get the same exact error you’‘re getting. There’‘s no documentation specifically related to voice that I can find. We want voice voice conferencing computer-to-computer, no phones. We can initiate a call, and the recipient gets prompted to accept, but the connection never happens. I can’‘t figure out whether we’‘re missing a plug-in or something, but it appears that it is supposed to work with a standard install, especially if there are no firewalls involved. Any help would be greatly appreciated. Love everything else about it…the super-easy LDAP (MS active Dir) integration and auto-group sharing features. Great fr internal corporate IM use. Just that darn voice that we can’'t figure out!

Thanks,

Chris

I think this is just something they need to do a lot more work on. I performed a clean install and voice started working again, but there was a horrible 3-second delay, rendering it unusable. I’‘m running the server on a dedicated box (nothing else on it) with dual 1.0GHz P3’‘s and 1.0GB Ram, Windows 2000. Shouldn’'t be a big deal. Then I enabled the media proxy feature and Voice stopped working, even after I disabled it again and stopped and restarted the service. What you have here is a very fine IM server and client, but the voice implementation appears to blow so far.

Message was edited by: chager00

If you are inside a LAN, voice will depends basicly on your network reliability.

Inside LANs, if you don’‘t have any firewalls, you don’'t need Media Proxy to perform Jingle Calls.

Media Proxy is used when App detects some kind of NAT or firewall blocking voice packets.

Which are UDP/RTP packets and uses ports from 5000 to 10000 of your pc.

Are you using any firewall in client machines?

Well, we’‘ve been testing it on four machines, two Vista boxes w/ standard firewall and two Windows 2003 Terminal Servers with no firewall at all. In no case does the firewall seem to have made a difference. When it was working it worked on all four machines, and when it stopped working it stopped on all four, and no firewall packet drops were logged. The fact that you didn’‘t respond with "Yes, it doesn’‘t quite work well yet" gives me hope! I can’‘t account for the delay. We’'re running VoIP for our PBX system with no voice quality issues and our LAN is relatively new with new Cisco hardware and gigabit ethernet everywhere, fiber for the uplinks. I would love to be able to use this for intra-office conference calls.

Message was edited by: chager00

Does this explain anything? I don’‘t know what any of this means - is it trying to connect to an external server for some reason? Is there a way I can configure this? The tags “jingle xmlns” mean anything? I’'ve only altered the password field.

You client is being told to connect to 10.100.1.193 on the specified UDP port.

What’'s the IP? The other client/media proxy?

10.100.1.193 is the IP address of my machine. The other machine is 10.100.1.206. I’'m going to post clean Spark Error and Output logs here in a bit after clearing the logs and trying to connect again…

Message was edited by: chager00

Ok, here’'s the scenario:

Chager@IM from IP address 10.100.1.193 places a voice call to bluh@IM at IP address 10.100.1.206. There are no media servers, this is a client to client connection on a gigabit LAN. Any insight is greatly appreciated! Both clients are running the Vista firewall, but Spark.exe is in the exception list. We get the same result when calling between machines without the firewall. All tests performed on a LAN with no other firewalling taking place.

The result in Spark is that the caller receives a message “Session Closed Remotely” and the call recipient receives the error about possible firewall interference.

Contents of error.log:

java.lang.reflect.InvocationTargetException

Exception on commit = java.io.IOException: Can’'t find registry file

Exception on commit = java.io.IOException: Can’'t find registry file

java.net.BindException: Cannot assign requested address: Cannot bind

at java.net.PlainDatagramSocketImpl.bind0(Native Method)

at java.net.PlainDatagramSocketImpl.bind(Unknown Source)

at java.net.DatagramSocket.bind(Unknown Source)

at java.net.DatagramSocket.<init>(Unknown Source)

at java.net.DatagramSocket.<init>(Unknown Source)

at de.javawi.jstun.test.demo.ice.Candidate.<init>(Candidate.java:53)

at de.javawi.jstun.test.demo.ice.ICENegociator.gatherCandidateAddresses(ICENegocia tor.java:67)

at org.jivesoftware.smackx.jingle.nat.ICEResolver.initialize(ICEResolver.java:67)

at org.jivesoftware.smackx.jingle.nat.TransportResolver.initializeAndWait(Transpor tResolver.java:384)

at org.jivesoftware.smackx.jingle.nat.ICETransportManager.<init>(ICETranspor tManager.java:36)

at org.jivesoftware.sparkplugin.JinglePlugin$1.construct(JinglePlugin.java:101)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:129)

at java.lang.Thread.run(Unknown Source)

Exception on commit = java.io.IOException: Can’'t find registry file

Exception on commit = java.io.IOException: Can’'t find registry file

0

BS:gsm

Track 0 is set to transmit as:

gsm/rtp, 8000.0 Hz, Mono, FrameSize=264 bits

Created RTP session at 11238 to: 10.100.1.206 17112

Contents of Spark Output.log:

DirectSound Capture Supported = true

DirectSoundAuto: Committed ok

JavaSound Capture Supported = true

JavaSoundAuto: Committed ok

Service listing

Public Chatrooms-result

Publish-Subscribe service-result

User Search-result

Initialized

1

Initializing…Resolved

Failed to commit to JMFRegistry!

Looking for Audio capturer

DirectSound Capture Supported = true

DirectSoundAuto: Committed ok

Finished detecting DirectSound capturer

JavaSound Capture Supported = true

JavaSoundAuto: Committed ok

Finished detecting javasound capturer

C: /10.100.1.193|/10.100.1.193 p:2195

Listening for ECHO: 10.100.1.193:11238

Service listing

Initializing…Resolved

UpdatePacketListener

Jingle: <iq id=“0B3b1-26” to=“chager@im/spark” from=“bluh@im/spark” type=“set”><jingle xmlns=“http://jabber.org/protocol/jingle” initiator=“chager@im/spark” responder=“bluh@im/spark” action=“transport-info” sid=“1172958821856276181”><content name=’‘Audio-Content’’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“10.100.1.206” port=“17112” network=“0” username=“1” password=“xxxx” preference=“2195” type=“prflx”/></transport></content></jingle></iq>

Jingle: <iq id=“0B3b1-25” to=“chager@im/spark” from=“bluh@im/spark” type=“set”><jingle xmlns=“http://jabber.org/protocol/jingle” initiator=“chager@im/spark” responder=“bluh@im/spark” action=“description-info” sid=“1172958821856276181”><content name=’‘Audio-Content’’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /><payload-type id=“4” name=“g723” channels=“1” clockrate=“0” /><payload-type id=“0” name=“PCMU” channels=“1” clockrate=“16000” /></description></content></jingle></iq>

Content Received: 1243105715037189522;10.100.1.206:17112

Result OK:10.100.1.206:17112

RESULT>>>OK:10.100.1.206:17112

Content Received: 1243105715037189522;10.100.1.206:17112

Result OK:10.100.1.206:17112

RESULT>>>OK:10.100.1.206:17112

Content Received: 1243105715037189522;10.100.1.206:17112

Result OK:10.100.1.206:17112

RESULT>>>OK:10.100.1.206:17112

Content Received: 5446499010682403007;10.100.1.206:17112

Result Wrong Data:10.100.1.206:17112

Content Received: 1243105715037189522;10.100.1.206:17112

Result OK:10.100.1.206:17112

RESULT>>>OK:10.100.1.206:17112

ADDED Valid Cand: 10.100.1.206:17112

Jingle: <iq id=“0B3b1-27” to=“chager@im/spark” from=“bluh@im/spark” type=“set”><jingle xmlns=“http://jabber.org/protocol/jingle” initiator=“chager@im/spark” responder=“bluh@im/spark” action=“content-accept” sid=“1172958821856276181”><content name=’‘Audio-Content’’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /></description></content></jingle></iq>

Content Received: 5446499010682403007;10.100.1.206:17112

Result Wrong Data:10.100.1.206:17112

Ignored Jingle(TYPE): <iq id=“0B3b1-28” to=“chager@im/spark” from=“bluh@im/spark” type=“get”><query xmlns=“http://jabber.org/protocol/disco#info”></query></iq>

Jingle: <iq id=“0B3b1-29” to=“chager@im/spark” from=“bluh@im/spark” type=“set”><jingle xmlns=“http://jabber.org/protocol/jingle” initiator=“chager@im/spark” responder=“bluh@im/spark” action=“session-accept” sid=“1172958821856276181”><content name=’‘Audio-Content’’><description xmlns=“http://jabber.org/protocol/jingle/description/audio” ><payload-type id=“3” name=“gsm” channels=“1” clockrate=“0” /></description><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“10.100.1.193” port=“11238” network=“0” username=“1” password=“xxxxx” preference=“2195” type=“prflx”/></transport></content></jingle></iq>

Jingle: <iq id=“0B3b1-30” to=“chager@im/spark” from=“bluh@im/spark” type=“set”><jingle xmlns=“http://jabber.org/protocol/jingle” initiator=“chager@im/spark” responder=“bluh@im/spark” action=“transport-accept” sid=“1172958821856276181”><content name=’‘Audio-Content’’><transport xmlns=“http://jabber.org/protocol/jingle/transport/ice” ><candidate generation=“1” ip=“10.100.1.193” port=“11238” network=“0” username=“1” password=“xxxxx” preference=“2195” type=“prflx”/></transport></content></jingle></iq>

Cand: 10.100.1.193

SET ACTIVE

Transport stabilished

triggerTransportEstablished 10.100.1.193:11238|10.100.1.206:17112

Jingle: <iq id=“0B3b1-31” to=“chager@im/spark” from=“bluh@im/spark” type=“set”><jingle xmlns=“http://jabber.org/protocol/jingle” initiator=“chager@im/spark” responder=“bluh@im/spark” action=“session-terminate” sid=“1172958821856276181”><content name=’‘Audio-Content’’></content></jingle></iq>

REMOVE PACKET LISTENER

Negotiation Closed: chager@im/spark 1172958821856276181

Bump. Nobody sees anything wrong/correctable?

Do you have any firewalls or antivirus running on the machines?

Cheers,

Thiago