Problems withTransferManager in Linux

I used smack 2.2.1 to make a java based system that transfers files from a client to another. As jabber server I am using Wildfire 3.1.1. Under Windows XP every thing works without a problem, but when I run the same java client under Linux Debian, the program crashes just when the next line of code is reached:

FileTransferManager manager = new FileTransferManager(Conn);

I tried all I read in this forum, even more, I changed to another based Linux computer and the problem remains the same. Next I show you the resulting Java log:

Exception in thread “main” java.lang.NullPointerException

at org.jivesoftware.smackx.filetransfer.FileTransferNegotiator.setServiceEnabled(F

at org.jivesoftware.smackx.filetransfer.FileTransferNegotiator.getInstanceFor(File

at org.jivesoftware.smackx.filetransfer.FileTransferManager.(FileTransferManager.j ava:64)

The JRE version is 1.5.0_10. Does somebody know what is going on here?

That is quite unusual. Which version of Smack are you using?



Hi Alex

Thanks for answering, I am using smack 2.2.1, I guess the problems is the Apache, In this moment I can c it is not working

In what way is an HTTP-server involved in this operation?