powered by Jive Software

provider.auth.className not Changed

Hi, I’m using Openfire@4.5.0-SNAPSHOT. I’m trying to switch from 4.2.0 to the new version. I want to a custom auth plugin. I did research, but I couldn’t come to a conclusion. How can I do this in the new version (so 4.5.0).

Well, it’s certainly possible to change provider.auth.className - but I suspect that the problem is that your customer provider is not on the class path when Openfire starts.

You say ‘plugin’ - are you doing this as a plugin? If so, you may need to separate out the relevant classes to their own JAR file and copy it to OPENFIRE_HOME/lib

HTH,

Greg

As you said I did and it worked but it gave error in my dependencies. I’m using com.mashape.unirest to send a http request within the plugin. When I compiled the plugin, I copied the plugin-lib.jar file to the distribution/target/distribution-base/lib directory.

And when I run this command to launch ./distribution/target/distribution-base/bin/openfire.sh I get the following error.

Exception in thread "main" java.lang.NoClassDefFoundError: com/mashape/unirest/http/exceptions/UnirestException

OK, sounds like you need either more JAR files, or a “fat JAR” in your OPENFIRE_HOME/lib folder.

Greg