powered by Jive Software

PSI Service Discovery of local server (Openfire) from Gtalk server help

Hi, I’‘ve been playing with Openfire for a few weeks now and I can’'t seem to do Service Discovery of the local services on Openfire if Im connected to the Gtalk servers. Example: I connect to my local Jabber Openfire server and I can do service discovery and see AIM, MSN, ICQ, etc listed as available resources. But if I connect to my Gtalk account then try to do Service Discovery it doesnt show anything. I know it works as I can browse other servers such as jabber.hot-chilli.net. Its this a bug (or feature? ) in Openfire of am I just an idiot? Any help would be nice as I plan on setting this up on a larger scale in a few months. I want to stick with the Gtalk servers as my Jabber service, hence the reason why I just cant use my own Jabber server.

Anyone? I really would like to get this working as it will be deployed large scale and it would be nice to have the end users add their AIM/MSN/etc accounts by them selves through Gtalk server rather than come to the network techs to have it done.

I’‘m having the same problem too! I’‘ve configured s2s connection with talk.google.com with port 5222. This won’'t show up in the service discovery in Psi. Any thing special have to be done for this?

I’‘ve been messing with it for a few hours over the past few weeks and gone through all the documentation but haven’‘t found anything helpful. Think I’'ll just go with eJabber as that worked on the first go. Kind of sad that even as a prospective large customer IgnitiionRealtime still refuses to offer some help.

Hi. I think I solved this problem. Are you running this server on a local machine? That’'s because, gtalk does a dialback ping to see if the requesting jabber server is accessible or not. So gtalk transport would work only on internet sites. I found this problem by checking the logs. Doing the same might help you.

Hmm, Ill try running on a remote machine and see. Thanks for the tip!