powered by Jive Software

Question Re: S2S and Chatting

So now I have s2s up and working, but can a person from domain A be in a chat room w/ peopel from domain B?

that would be superb if so… or is this a limitation of s2s stuff?

thanks for any insight!

-Craig

I havent tried but i think i’ve seen this working. I mean some people were joining the Live Chat at igniterealtime.org via s2s. So i think it should be possible. Is it not working for you? What errors do you see?

Hey Wroot… thanks for the reply.

So the error’s I get are (note the Jabber Client i’m using is Pidgin)

Pidgin reports a 404 - Remote Server Not Found…

So when a user from user@domainB.org tries to connect to a chat room in conference.chat.domainA.org

a 404 is returned, I also noticed in the debug log I get this…

2009.05.01 11:05:33 OutgoingSessionPromise: Error sending packet to remote server:

1



java.lang.Exception: Failed to create connection to remote server
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:252)
at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:216)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

But if it is Failing to create a connection to the remote server, how can the users even chat outside of a chat room???

odd no? Just as an FYI, there are 0 firewalls between these two servers, and they are on the exact same subnet.

any ideas?!

Are you using servers’ names to define s2s connections? Maybe they just cant resolve those names, maybe you can use IP’s instead.

what i’m using to attempt to join the chat room is

conference.hostname.domainA.com

so a user from domainB is unable to poll rooms or connect to rooms on

conference.hostname.domainA.com

Also… IP address did not work either, good suggestion though…

I’m stumped…

just an FYI … fixed it…

in my s2s settings…

under white list…

i had to add conference.hostname.domainA.com so that user on domainB could access it, problem is solved now…figured this out by doing a google search… and found this page…

http://www.igniterealtime.org/community/thread/36992

Just closing it up since its resolved. prior post explains resolution…