powered by Jive Software

Random Transfer Issue with File Transfers

I have an odd issue here. I’ve had Spark and Openfire set up in my environment for quite some time and have no issues whatsoever save for the occasional file transfer issue. It is seemingly completely random. I check firewall logs, nothing is blocked. I’ve tried with and without the proxy service. I’ve also excluded that proxy port in our firewalls when it was enabled. Any advice or ideas would be much appreciated. Currenly running Spark version 2.9.4 and Openfire version 4.6.7.

file transfers have been an issue for a while. One thing to check is to see if IBB is selected on both clients. It should, as its the default.

Yes, it is indeed.

something else to try may be to give Spark 3.0 (beta) a spin. no promises though! :smiley:

Haha, yeah! I have and was the same result. Bummer! Any other thoughts?

might try the nightly build. also which the 3.0 beta, I think changed the default behavior for transfer and IBB is disabled by default. may give it a go with IBB enabled.

Spark 2.9.X has an issue with IBB. If the client lost connection and reconnected then file transfer will not work. By the way, this fixes the Smack update to the 4.4 branch. I would recommend:

  1. Disable IBB . It worked for my company!
  2. Or use last Nightly build Spark 3.0.0(it uses smack 4.4)
1 Like

Brilliant! Thank you both for your help, but I think disabling IBB is going to be the answer. We’ll wind up going with Spark 3.0 at some point, but it does have a major interface change and I don’t think my users are ready for that. Haha!

Thanks again!