powered by Jive Software

RANT: Unable to login to Admin Console after the installation

I installed Openfire 3.6.4 on Win 7. Install seemed to go smoothly (embedded db, default users & groups).

Then i couldn’t login to the admin console.

I tried restarting the server.

I tried the authorizedJIDs thing.

I tried setting setup to false, and going through the setup again.

I looked at the entry in the OFUSER table in the embedded-db-viewer

I tried to to look at http://www.igniterealtime.org/issues/browse/JM

but that’s the wrong link. The correct link http://www.igniterealtime.org/issues/browse/OF

Found http://www.igniterealtime.org/issues/browse/OF-217

OK, so I have to build from source to get the patch r11017 from more than a year ago (May 2009) ?!

But at this point I’m wondering whether that’s worth the effort. If indeed trunk head fixes this fundamental problem, will the rest of it work properly? Why has it been so long since the last release?

I guess i could use MySQL, that might work, but I don’t really want to try that now.

http://www.igniterealtime.org/projects/openfire/index.jsp promised me “Openfire is incredibly easy to setup and administer”. Not true in my case. Who knows how many other people are being put off by a similar experience. Lots, judging by the number of times this has come up in the forums.

Hi,

in any case you should be able to create accounts once the server is running. And you could then stop Openfire, add this account to openfire.xml as an authorized JID and start Openfire again. Then you should be able to login using the new account.

LG

Thanks for the suggestion.

Instead I built from svn head tip, and was able to login successfully with that.

2 small things that came up:

  1. build.xml should be changed to allow building with ant 1.8.x

  2. the last line of openfire_hsqpdb.sql gives an error since “MILLIS” is mis-spelt as “MILIS”

Your rant is pointless as i doubt any JiveSoftware employee will see it and we (community users as you are) can’t do much about it until they fix the build server and let us do a new release.

Ant issue is already filed in the bug tracker.

  1. fixed in trunk .oO(how could I miss this typo)