I’'m no expert in SQL server, but i was able to get wildfire running on a trial edition of sql server 2000, with it reading our username list out of ldap.

Problem is, the 2000 trial ended, so wildfire was shutdown. We have since gotten a full edition of 2003 and i have gone through the steps i remember, install wildfire, create database, make user, insert sql, change xml pref. but i can’‘t get it the sucker to start up, keeps giving me errors. unfortunately I did not keep good notes of my exact procedure from before, so I am not sure of what i am doing wrong. One thing i did notice is in my old xml pref i had a port number after the server name(jdbc:jtds:sqlserver://KAPSERVER2006*:1609**/wildfire;appName=jive*), while in the default xml supplied with wildfire it does not have have a port listed. Here’'s my error code below:

2006.10.26 14:19:13 [org.jivesoftware.database.ConnectionPool.(

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(

at org.jivesoftware.wildfire.starter.ServerStarter.main(

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

Caused by: java.lang.NullPointerException

at org.jivesoftware.wildfire.XMPPServer.verifyDataSource(

… 16 more

The default port for SQL Server is 1433. Are you sure that you have the correct port for the new SQL Server install?



How do I view the ports? I was looking for that earlier… I did it before but can’'t remember.

What OS is the SQL server running on? Also, you said you purchased a full license of 2003. SQL comes in a few flavors, but 2003 i don’'t think is one of them. Did you mean 2000 or 2005?

One thing to check, if you are running SQL 2000 on Window 2003, you will need to be running SQL SP3 or higher. If not the OS is smart enough to not allow network requests to the SQL server.

Do you have the Enterprise Manager or Query Analyzer running on any other system besides the server? Can you remotely connect using Query Analyzer from another machine to the Server?

From the error logs, the connection is being refused. either the SP hasn’'t been applied or the proper protocol was not correctly set in the Server Network Utility (something like: C:\Program Files\Microsoft SQL Server\80\Tools\Binn\svrnetcn.exe).

Try the above and get back with us.

oh sorry, im running MS SBS 2003 with SQL 2005. The problem is, we had another application that would only run on server 2000,and my first wildfire install was successful when i used that. Now that i am trying to set it up to run with 2005 (2000 trial ended) i am getting this error. I also tried the default sql port number, as suggested above, but still no dice. I can set up the database in enterprise manager and run the scripts for it… what i was thinking was that i had a port or reference error, but Im not sure how to display SQL’'s setup/config/etc info.

You can configure the ports using:

Server Network Utility (something like: C:\Program Files\Microsoft SQL Server\80\Tools\Binn\svrnetcn.exe)

or open up Enterprise Manager, right click your server and go into the properties. On the General Tab, you should see a button near the bottom, “Network Configuration” (it opens the same as the above).

I’'ve not worked with 2005 yet, but if you actually have the CD, can you install Query Analyzer on another machine and verify that you can connect to the server?

wow. I am an idiot… atleast i can blame it on i did not set this up. i checked the version and it is Version 8.00.2039 (looking on the web i saw it was SQL Server 2000 with SP4). I can connect to it while on the server, but have not tried from another machine.

so that means i had two installs of SQL 2000 running, one a trial and the other a built in. The trial expired and i tried to get it working on the installed version with no luck.

Yes, unless you have SBS 2003 R2 (just released) you better not have SQL 2005 running on your server. The reason is that SBS uses SQL 2000 or MSDE from the same 2000 product family to run many things including your Companyweb SharePoint site. If your users are like mine you don’'t want that getting mucked up. R2 has moved things over to SQL 2005 but there is NO procedure for doing this. The instructions for SBS SP1 include information on upgrading instances of SQL to SP4. If you are running SBS premium then you also could have potential ISA 2004 misconfiguration issues but hopefully not. Before trying any tweaking with ISA I strongly recommend creating a safety net by running the ISA backup. Then you can blow all the settings away, run the CEICW aka Configure Exchange and Internet Configuration Wizard (To Do List from Server Management Connect to Internet) and make certain you to a) choose to use the firewall b) choose to change the firewall settings c) choose the right options for remote user functionality.

I didn’‘t like the idea of messing up my SBS server and deployed Wildfire Server on an XP workstation. Later I knew I could play with a server deployment but I don’‘t like the idea of putting a beta-ish third party app on a business critical machine. You might also consider doing the same and beyond XP you could also add a member server. R2 will give us expanded useage licensing rights to doing this very thing. You won’'t need to buy SQL access CALs but you will have to buy whatever flavor of SQL you wish to have on the member box.

I blogged about adding WSUS 3.0 onto a sandbox SBS Prem and what the tagalong requirement of pushing SQL 2005 into it did. It wasn’'t good.

my mostly SBS blog