Really stuck on this HTTP:500 error!


wildfire version 3.0.1 on a gentoo box. i followed install instructions here:

When i start wildfire, even as root I get the HTTP 500 error when I hit continue on the first setup page.

I have one entry in my hosts file, localhost

Thats it. What other permissions need to be granted or set? I’'m at a total loss here!


so I assume there were no problems during installation. Do you see errors in the log files?


Right now nothing in errors.logs, there was a bunch (mostly from me accidentally trying to start it twice in a row) I cleared them, and started it again and tried going through, and it still says error 500, and nothing else in the logs

stderror.log has: Error starting admin console: multiple exceptions

admin-console.log has :13:00:27.945 WARN!! [pool-1-thread-1] org.mortbay.util.ThreadedServer.start( >17> Failed to start: SocketListener


This is pretty frustrating, considering wildfire works fine on another server that I was only upgrading to version 3, and the upgrade went very smooth too.

I dont understand how I can’‘t even install wildfire when java is installed, the path is set, there really isnt that much that I could’'ve done to screw up here.

Are there other things I need to do that arent explained in the guide? Things that are assumed of a person installing wildfire?

Hi Mellman,

I’‘ve seen similar error a number of times in this forum. The problem boils down to not being able to kill/clear the previous instances of Wildfire properly. Assuming that you run on Linux, perhaps you’'d want to play around with the options you pass to ps to check for running processes. On my system, ps auxw | grep wildfire reveals everything.

Thanks for the reply,

I would agree with you, but this has happened since the first time I ran the program. I have yet to get past the language selection page on the install, on any of the 3 servers ive tried to install it on.

The only server I have version 3 (or any version for that matter) running on, is the old server, where wildfire was already installed. At this point I am convinced theres a step missing in how to setup wildfire…


as you get the first setup page .oO(…) did you enable cookies in your browser?


Edit: If you have a running Wildfire 2.x installation you might use the existing database ((embedded-db/*) and conf/wildfire.xml file - this should work fine, so you don’'t need to run the setup.

If you use an external database be sure to make first a backup - Wildfire 3.x will update the database schema version and it may not be compatible with 2.x.

yes - cookies have been enabled. i setup the other server fine- no idea why this one won’'t work.

I cleared cookies, and turned security settings to the lowest, cleared history and temp files, and verified they were gone. still get this:


gentoovm: gentoovm


Powered by Jetty

something, somewhere, isnt able to execute what it needs to do to generate this setup-host-settings.jsp page…


==> Which java version are you using?

==> Did you “Add “INSTALL4J_JAVA_HOME_OVERRIDE=/opt/java/jdk1.5.0_08/jre” as the second line to WF/bin/wildfire to make sure that this JVM will be used.” ?

gentoovm is the machine name.

path is set to use JRE 1.5.0_08 And thats what its using.

I did uncomment that line in wildfire, and it changed nothing. so i had changed it back. there is only 1 version of java installed on this system, and only 1 version of java set in the path. its a very clean install on the box, nothing else runs on it, it was setup just for wildfire and a few other apps that will be configured/installed later.


when i start wildfire i see this:

wildfire # bin/wildfire start

testing JVM in /opt/jre1.5.0_08 …

bin/wildfire: line 63: /root/.install4j: Is a directory

Starting wildfire

nohup: appending output to `nohup.out’’

what is /root/.install4j and why is it giving me that ?



I really wonder what’'s going on. Did Wildfire extract the .pack files in the lib directory?


there are no pack files in /WF/lib. these are the files there.

lib # ls -al

total 8176

drwxr-xr-x 2 root root 4096 Sep 7 14:08 .

drwxr-xr-x 10 root root 4096 Jul 13 16:42 …

-rw-rr 1 root root 54829 Jul 13 16:39 activation.jar

-rw-rr 1 root root 1070477 Jul 13 16:39 bouncycastle.jar

-rw-rr 1 root root 111388 Sep 7 14:08 commons-el.jar

-rw-rr 1 root root 629372 Sep 7 14:08 hsqldb.jar

-rw-rr 1 root root 349609 Sep 7 14:08 jasper-compiler.jar

-rw-rr 1 root root 105531 Sep 7 14:08 jasper-runtime.jar

-rw-rr 1 root root 74639 Jul 13 16:39 jdic.jar

-rw-rr 1 root root 282625 Sep 7 14:08 jtds.jar

-rw-rr 1 root root 347137 Jul 13 16:39 mail.jar

-rw-rr 1 root root 451545 Sep 7 14:08 mysql.jar

-rw-rr 1 root root 397448 Sep 7 14:08 postgres.jar

-rw-rr 1 root root 133622 Sep 7 14:08 servlet.jar

-rw-rr 1 root root 59483 Jul 13 16:39 startup.jar

-rw-rr 1 root root 57344 Jul 13 16:39 tray.dll

-rw-rr 1 root root 4143883 Sep 7 14:08 wildfire.jar

Yeah I know they’'re owned by root - but right now i just want to get it working, i can change permissions later.

deleted the wildfire directory, started from scratch (re-extracted from the tar)

pack files are now in there…i start wildfire and same as before HTTP:500

:smiley: i feel like im going crazy over such a (what should be) simple error


hosts file was missing the machine name…

so I added gentoovm next to localhost in my hosts file and it got to the 2nd page…

So I wonder if this is a general gentoo problem … you could try to use

another linux distribution or

a this installation with a database and wildfire.xml file of a running installation?


Well - I dunno, but I think its something that should possibly be added to the help documentation just to make sure? hm…


it would be nice if another gentoo user could post whether it’'s working or one does need to tweak things or use another java version.


I just tested this on my other box, using java version 1.5.0_06 - wildfire version 3.0.1, added the machine name to the host file and it worked like a charm. I suppose this issue wouldn’'t happen if the machines had entires in DNS?

Here is what I think the problem is - it really seems like the problem is the next page (after the language selection page) is that its trying to autofill the server name section. This is probably what’‘s causing the page to show up if your host file does not have your machine name in it (these machines arent memebers of the domain so they don’'t have a domain)

Ended up not even using LDAP - because I don’‘t think that the built in LDAP configuration uses encryption? could be wrong there but the default port isnt encrpyted. Also it looks like you can’‘t have users auto-joined to a group when they sign on the first time. This would be a nice feature, i’'ll post it in the dev section.