powered by Jive Software

Recipient sometimes doesn''t gets messages

I have developed an Messenger client using agsXMPP library version 0.5.0.0.

Sometimes im my application it happens that the recipient doesn’'t gets the message.

I am not getting what is the problem. Is this is a agsXMPP problem or XMPP problem or my application problem ?

I am using Jive Messenger, Version: 2.2.2 as my xmpp server which is running on my development machine (Intel Pentium 4 CPU 3.00 GHz, 512 MB RAM).

Everyday around 40 messenger clients connect to this jive server and at the same time I do my development work. SQL Server 2000 is also running on my machine.

I think why the recipient sometimes doesn’'t gets the message is because everything is running on my development machine.

I am planning it to move to a proper server. Also the agsXMPP library I used is old one, so I need to replace it with new one.

Also the jive messenger server I am using is old one that also I need to replace with latest version.

Am I thinking in the proper direction ? Can u guys pls guide me to solve this issue.

Hi,

I never saw a bug that Jive Messenger that random messages got dropped. There were anyhow if I remember right some problems storing offline messages which did contain unicode characters.

I’'m not sure if JM 2.2.2 does have the “audit log” option, which enables one to trace all messages, maybe agsXMPP offers a way to trace all received and sent packages?

Do you see errors in the JM error.log file?

LG

http://www.jivesoftware.org/community/thread.jspa?threadID=19391&tstart=0

Hi,

what do you want to tell me submitting this link?

Are you using s2s and messages are dropped if the users are connected to different servers?

Or you are not using s2s but you see sometimes an s2s exception? Then disabling s2s will help a lot or one may configure the client to use the right xmpp domain.

LG

I submitted that beacuse that is what I see in error.log.

Or you are not using s2s but you see sometimes an s2s exception?[/b]

This is true. Ok now I am going to disable server 2 server communication.

Thanks for replying.