powered by Jive Software

Red5 0.0.10 Openfire 3.4.1 issues

I currently have Openfire 3.4.1 and the Red5 0.0.10 plugin installed. I try to navigate to http://mydoman.com:9090/red5 and I simply receive:

HTTP ERROR: 404NOT_FOUND

RequestURI=/red5

+[Powered by

Jetty://|http://jetty.mortbay.org/]+

The Red5 plugin is listed in the Admin console. I ran across a thread that stated red5.enabled=true needed to be added to server properties and I have done so. Anyone else have this problem or preferably a solution?

check your fire wall and see if port 9090 open.Are you using mac windows or linux

My server is OpenSuse 10.2, port 9090 is open in the software firewall and my Cisco Pix. I can access the admin console just fine by mydomain.com:9090 remotely. However, mydomain.com:9090/red5 gives me an http error stating there is no such directory. I attempted to place just JWChat in the /spank directory and use http-binding. I opened port 8080 in both software and hardware firewalls. I can access the page from mydomain.com:8080 or using Apache ProxyPass mydoman.com/jwchat/. When I try a login the list window comes up and immediately proceeding is “Service Unavailable”. Any ideas?

I am still using openfire 3.3.3 as the 3.4.1 still has bugs.with red5 and jwcat I can login but the jwchat contacts roster dos not work and the add contact dos not work.Ihave both servers and still use the 3.3.3 as my main server! and am wating on the bug fixes

Do you know where I can download 3.3.3? Thanks for the help.

I have the windows exe with one of the older red5 plugins if you want use my contact info and I will file transfer it to you.

Hello Thomas There is a red5 server for Linux the openfire red5 mite work on linux as for where to get a Linux copy of openfire 3.3.3 I only have the windows.

here you can fined the red5 server it has download for windows Mac and tar ball for Linux ana unix

http://osflash.org/red5/063final

this has to be instaled on the same computer as the openfire for the red5 plugin to work

You can download OpenFire 3.3.3 from right here at igniterealtime.

Windows exe is http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3_3_3.exe

Linux rpm is http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire-3.3.3-1.i386.rpm

Mac dmg is http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3_3_3.dmg

For me, 3.4.1 with Red5 v0.0.10 caused the add contact button in Red5 JWChat not to work.

So I attempted to use 3.3.3 with Red5 v0.0.10.

The login works, the add contact works, even “Register New Account” works…

Anytime I try to send a message I get “Error 404” within JWChat.

Anyone know why?

I also tried using Red5 v0.0.9, but this caused the add contact to stop functioning again, as well as not being able to start a conversation.

I gave him the red5 09 to day.As for jwchat start new build then expot improt clients that should fix

the jwchat with openfire 3.3.3 and red5 09 the openfire 3.4.1 dos not work I have that build as well but jwchat have no contacts roster no add contacts no messaging.where is the red5 V0.0.10 down load

I’ve updated my reply to include Windows, Linux & Mac

…We’re chasing eachother’s tails being on at the same time

You can download red5 v0.0.10 from http://red5.4ng.net/red5.war

This is my jwchat on the openfire 3.3.3 red5 v 0.0.9

come chat and try out the webcam cafe chatroom

http://kingshomeworld.com:9090/red5

JWChat the new look




I took another run at openfire 3.4.1 with the red5 0.0.10 with new install and new databaes and got the same results jwchat has no contacks roster and no add contacts.Still logs in as of line.With windows xp java 1.6 3D

Hi everyone,

Unfortunately, I am not using red5 yet on my 3.4.1 install so I can’t confirm what the problem is. I am working on a new flex based client too;) .

I however suspect that there could be issues with the red5 plugin (all versions) and Openfire version 3.4.1. I tried to comple 0.0.10 version against 3.4.1 openfire.jar file and I got some errors for my effort. I think that a number of things have changed internally due to the clustering.

As soon as I get a break from my day job, I will take a look at fixing them. In the meantime, if anyone does manage to recompile with openfire 3.4.1, please post the jar file here.

-dele

this flex client you are working on will it be available for the openfire server are you going to have video on your client

Hello Dele I have traced the problem down to the new change to the AsteriskWin32 phone .the jwchat works with the red5 0.0.10 until I set up the phone connections and the Asterisk connects to the red5 gateway after that the jwchat roster and the add contacts shuts down.So the problem must be in the new changes to the phone manager installing into the red5 gateway.this happens on both openfire 3.3.3 and 3.4.1 I no you have little time to spar I hope this can help shorten the time to fined the problem

I upgraded my server and I am using Apache HTTP Server with no configuration modifications involving Red5.

This configuration works for chat right out of the box: (at least, it did for me with a completely clean install of everything)

OpenFire version 3.3.3

Red5 version 0.0.9 (that’s considered an ALPHA version number folks, as is 0.0.10;

We’re all just lucky that Dele is releasing it in the first place! TY TY TY TY ! )

I don’t know much about setting up video or the other red5 features yet (so I cannot vouch for those functions), but JWChat is sending and receiving messages from both local and remote user accounts.

BY THE WAY:

I noticed that the ‘Add Contact’ button seemed to work only intermittantly. To solve this, Clear your browser’s cache! Reload alone doesn’t work (weird).

This may also be the cause of other problems, such as that 404 Not Found.

If you are using the openfire with red5 jwchat then you dont put the jwchat in your apache but leave it in the openfire plugins file and use http://yourdomain.com:9090/red5/ to access jwchat.

I have the same problem with browsers but not the add contacts but refreshing changes.I use mozilla firefox and explorer.how do I clean the catch.as I am making changes to the JWChat for the next gen. of JWChat.Some in looks and functions and would like to get the refresh working some what faster with out that it takes much longer and much more work to test changes

You have a few alternatives:

  1. With your code.

With JavaScript 1.2, the refresh code should be:

window.location.reload( true );

This SHOULD cause a complete reload of the page; however, I’ve seen instances where it still loaded a page from the cache.

  1. Disabling the cache.

In FireFox 2.0, navigate to about:config

Locate browser.cache.disk.enable and double-click it, so it’s value reads false.

Close that window.

Now manually clear your cache, as layed out in #3.

I am unsure if you need to restart FireFox, so you might want to do that just in case.

For Internet Explorer

Open the Tools menu, then click Internet Options…

In the General tab, under the section Temporary Internet Files, click the Settings… button.

The Settings dialog opens.

Under Check for newer versions of stored pages:, click the option Every visit to the page

Click OK; then click OK to close Internet Options.

  1. Manually clearing cache.

In FireFox 2.0, click on the Tools menu, then Options.

In the Privacy tab, there is a section labeled Private Data.

Click the Settings… button.

Deselect data you do not want cleared. I usually set mine to have Cache and Authenticated Sessions checked, and the rest unchecked.

Click OK.

At this point, you’ll be back in the Privacy tab. To save time, uncheck Ask me before clearing private data then click Clear Now…

Click OK, then Click OK to exit the Options dialog.

>> From this point forward, when you want to clear your FireFox cache (and anything else you selected for clearing private data), you can simply go to the Tools menu, then click Clear Private Data (or use the keyboard shortcut of <ctrl><shift><del>).

For Internet Explorer

Open the Tools menu, then click Internet Options…

In the General tab, under the section Temporary Internet Files, click the Delete Files… button.

You do not need to checkmark the “Delete all offline content”; just click OK.

Click OK to close the Internet Options dialog.

Repeat this process to clear your cache anytime.

My only words is thank you very much