Red5 install issue

Hey folks,

I’m trying to install Red5 plugin without success.

Tried to install versions 0.0.18 and 0.0.23

My server is a WinXP SP2 with java JRE 1.6_06

Im receiving this log when i start openfire:

02/07/2008 14:47:54 org.jivesoftware.openfire.plugin.red5.Red5Plugin initializePlugin

INFO: Initializing red5 Plugin

02/07/2008 14:47:54 org.jivesoftware.openfire.plugin.red5.Red5Plugin startPlugin

INFO: Registering red5 as a component

02/07/2008 14:47:54 org.jivesoftware.openfire.plugin.red5.PacketHandler startPacketHandler

INFO: Starting PacketHandler

02/07/2008 14:47:54 org.jivesoftware.openfire.plugin.red5.Red5Plugin initialize

INFO: Creating web service red5

2008-07-02 14:48:04,921 INFO org.red5.server.jmx.JMXAgent - JMX HTML adapter was not enabled

2008-07-02 14:48:04,953 INFO org.red5.server.jmx.JMXAgent - JMX RMI adapter was not enabled

2008-07-02 14:48:05,953 INFO - RTMP Mina Transport Settings

2008-07-02 14:48:05,968 INFO - IO Threads: 2


14:48:05,984 INFO - Event Threads - core: 4,

max: 8, queue: -1, keepalive: 60

2008-07-02 14:48:06,046 INFO - TCP No Delay: true

2008-07-02 14:48:06,078 INFO - Receive Buffer Size: 65536

2008-07-02 14:48:06,093 INFO - Send Buffer Size: 271360


14:48:06,171 INFO - RTMP Mina Transport bound


2008-07-02 14:48:06,187

INFO org.red5.server.jmx.JMXFactory - Object name:



14:48:06,312 INFO org.red5.server.jmx.JMXFactory -

Object name:


Red5SIP starting in scope sip C:\Arquivos de programas\Openfire\bin

I found other posts about this issues, but dont see any about my case, because of that i open this thread.

I tried to change http bind port to 8080, nothing happened.

Any tips are wellcome.

Thx in advance.


Do a quick check on your Plug-ins folder, and make sure that Red5 has it’s own folder - it should have been created when you installed the .war via the plug-in page on OpenFire’s administration interface. Did it create a Red5 folder?

Yes Smittles, the Red5 folder are created normally.

The plugin open with no problems when i use the openfire admin console, and i tried to change the http bind port without success.

Thx for ur help.

How recent is your installation?

If you’re using[ Dele’s new 0.0.22,|m-173628] you may want to configure your HTTP to 7070, and see how that works. If that doesn’t work, uninstall red5 (from the admin console), and see if you can get a hold of the older plug-in, and then try 8080.

I´m using 0.0.23 version.

But i think the Red5 is working, despite that the log is showing erros during deploy.

I tried again putting on 7070 http bind port and reinstalling spark plugin. Then tried to share desktop and are working fine.

And now the http://server:7070/red5 are working fine too…then, i think the problem is solved, now only need to know more about that errors in log, but thats not the most urgent thing.

Thank you so much Smittles.

Best regards


The messges you get are info messages from the red5 server. If you want to reduce the messages and keep it very quiet, then edit the logback.xml file in WEB-INF\classes. The messages from the red5 plugin will be tidied up at some point in the future.

Deploying the red5 plugin hot (while openfire is still running) does not work and I have not found a solution yet. The only way is to stop openfire before you copy the red5 plugin to the plugin folder otherwise you will get errors and red5 plugin will not create the red5 web service in the http-bind port (deffault 7070).


Perfect answer dele, sinthethyze all things i done here.

  • Yes, you are right, are info messages, dont errors.

  • Thanks for the tip about where to edit the red5 logs config.

  • Yes, hot deploy wont work (get errors and no red5 web service).

Many thanks for your help.