powered by Jive Software

Red5 is not installing probably

Hi,

there are much threads to this kind of failure but no solutions.

I’Ve got openfire 3.6.4 running under gentoo for 2 1/2 year now.

Today i want to install red5, i’ve got downloaded http://red5.4ng.net/red5-0.1.11.zip, stopped openfire, unzipped it to /opt/openfire/plugins/, stated openfire

after that, this is in the logs:

2009.07.20 11:16:36 [org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.jav a:507)] Error loading plugin: /opt/openfire/plugins/red5
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :385)
at org.jivesoftware.openfire.container.PluginManager.access$300(PluginManager.java :47)
at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:1032)

i don’t know what is wrong, hopefully somebody can help

the failure was, that openfire was running with java 1.5, this setting was in /etc/init.d/openfire

so i set it to 1.6 and everything runs…