powered by Jive Software

Red5 SparkWeb Can't Create account!

When I am trying to use to create account with sparkweb (red51.0.4,openfire3.2)?

the sparkweb occured the error :“bad-request”. Is it a bug?

create account now works with latest versions. Openfire 3.6.2 with patch for SparkWeb TLS and red5 plugin 0.1.08

I am sorry to ask that how to get the SparkWeb TLS patch for openfire 3.6.2 ?

Actually I still have errors with the latest version of Openfire 3.6.3 and your latest Red5 plugin 0.1.08.

And saying the truth I’m not able to create an account even with the “normal” sparkweb that I put under “openfire\plugins\admin\webapp”.

But I’ve already checked the “in-band” setting and I’m able to create users directly from the openfire admin console.

The “normal” sparkweb version answers with a “bad-request” message.

The Red5 sparkweb answers with an “unable to create user” message.

Can it be because of a firewall port different from the ones already opened that are 5222, 5223, 5229, 5230, 7070, 9090?

Mauri

An update…

With OF 3.6.3 and Red5 SparkWeb 0.1.08 even the login stopped working.

The Login button become disabled after clicking it…

Going back to OF 3.6.3 and Red5 SparkWeb 0.1.02 (last version available on the igniterealtime.org site) login works fine but Create New User generates the following warning in the logs

2009.01.23 21:30:28 User tried to authenticate with this server using an unknown receipient:


gigi
gigi

Any hint?

Ok, solved removing the domain plus extension part when trying to connect or create a user in the @ part…

Example:

I was using

newUser @ myServer.myDomain.com

now I just insert

newUser @ myServer and creation or login work fine.

I suppose I have a bad configuration file somewhere…

Openfire 3.6.3 does not work with red5 SparkWeb 0.1.08 making TLS socket connections. Either set TLS to false in index.html or use patched openfire.jar

Can you tell me how to modify the openfire code to fix the bug?

I can’t download the patched openfire.jar :(,and then I modify the index.html set TLS to false as bellow:

connectionTLS: “false”,

But I still can’t create the account,though I can login the SparkWeb now.

The openfire version is 3.6.2 that I download the code from svn and built the code myself.

Can you tell me how to modify the openfire code and to fix the bug?

Thank’s