powered by Jive Software

Red5 Sparkweb fails to login, where to go from here?

I’ve been using Sparkweb deployed to lighttpd for a while, but have been missing chat history, so I decided to install openarchive and the red5 sparkweb to make use of it.

After a few lack-of-documentation-bumps in the road, I downloaded the 0.1.08 red5 sparkweb plugin, built the war with the _makewar.cmd, copied the war to my openfire plugins folder, gave it time to deploy, checked my http-bind setting, and tried the client. The red5 sparkweb login appears when I connect to (also accessing from outside the network via domain name does the same), however entering my login info and clicking login does nothing, it just sits and waits, ie’s status bar says waiting for indefinitely. (just tested with mozilla with same results)

Any ideas? What steps should I take now?

I tried looking through the openfire server logs but didn’t see anything seemingly related to red5. I can post whatever anyone requests.

PS this is using openfire 3.6.2 running on windows xp sp3 with java jre 1.6.0_03 (I built the war with jdk 1.6.0_13)


Edit: Just realized there was a more modern version (0.1.11) so I uninstalled the red5 plugin, reset openfire, deployed the new red5, reset openfire, same result (new version did deploy, slighty different ui and different backdrop).