Red5 webphone doesn't send any SIP packets


I am currently testing the Red5 webphone. Thanks to the documents on this forum (specially the DOC-1520), I could install Wildfire with a running Red5 plugin (v 0.27) on my Debian box. I could use some of the red5 example applets, all fine.

My problem is now that the Red5 webphone doesn’t send any SIP packets (no REGISTER, no nothing).

In the RED5Phone (New User Interface), I have set the following info :

Username : my_user_name

Password : my_password

Mailbox : none

SIP realm : my_SIP_provider_realm

SIP server : my_SIP_provider_IP

RED5 URL : rtmp:/sip

I have a message “connection success” (and indeed, grepping the network traffic, I can see my web browser and my red5 server talking).

Nevertheless, the Red5 plugin doesn’t send anything to my my_SIP_provider_IP (public IP address). For info, I have an asterisk server running on the Debian box as well, connected in SIP to the same SIP provider.

Does anyone would have an idea what the problem could be ?

(Later I would like to install the standalone server but, one step after the other )

Thanks !


check your log files especially the SIP log files generated by the mjSIP java client.

what sip server are you using?

Hello Dele,

Thanks for your answer. As far as I can see, the Red5phone doesn’t produce any log file. Here is the sip.cfg file in the red5phone directory :





But there is no logs directory in the …/. I also would like to mention that, when I enter my SIP infos, the webphone just says ‘connexion succesfull’, but I

the image remains the same, i.e. I have no dialpad. If you have any idea concerning this issue…

Thanks again and regards,


Hello Yaya,

The proxy is based on OpenSER, but I don’t think that it is relevant since no communication is set so far batween the two servers (the openfire server doesn’t send any SIP packet anywhere).

Thanks and regards,


if you are running openfire from openfiire_home/bin, then …/logs should be pointing at the openfire logs folder. Otherwise make sure you are running from the bin folder and then check the logs folder for the SIP client log files.

Well, I am not sure that it runs from any bin directory. I just install the .deb package (using dpkg) downloaded from here. The root folder is /usr/share/openfire. Then, in this folder, I have the following files/directoies :

lrwxrwxrwx 1 openfire openfire 13 2008-08-01 14:04 conf -> /etc/openfire
lrwxrwxrwx 1 openfire openfire 29 2008-08-01 14:04 embedded-db -> /var/lib/openfire/embedded-db
drwxr-x— 2 openfire openfire 4.0K 2008-08-01 14:04 lib
lrwxrwxrwx 1 openfire openfire 17 2008-08-01 14:04 logs -> /var/log/openfire
lrwxrwxrwx 1 openfire openfire 25 2008-08-01 14:04 plugins -> /var/lib/openfire/plugins
drwxr-x— 3 openfire openfire 4.0K 2008-08-01 14:04 resources

openfire is started using /etc/init.d/openfire start

I can see some log files in /var/log/openfire, but none of them contain any information concerning the SIP.

I can see some log files in /var/log/openfire, but none of them contain any information concerning the SIP.

Are you absolutlely sure? Check red5.log and red5error.log. There is an answer or clue somewhere in that log folder. I can tell you that it won’t work if the application home folder is not openfire_home/bin. That is the reference point and it wont find the codecs folder and your SIP logs are somewehere else. …/logs relative to your start folder.

I am sure. I have scenned the whole disk looking for red5 files but no log files have been found. One extra info : earlier, I have installed the red5 standalone server, I removed it in the meantime. Today, I have de-installed and reinstalled everything from scratch (openfire and red5 plugin), but the problem is still the same. Do you think I should use some earlier version of red5.war ?

zip all files in your logs folder and send them to me.

I know it’s not nice, but for troubleshooting you could try to change the log directory in the configuration to an absolute path, e.g. /tmp

Make sure it is a directory, not a file.

This might even fix red5phone :slight_smile:

I have it working on ubuntu installed as a plugin for openfire (which I don’t need at all, just couldn’t make red5phone work on a standalone red5…)

I had to configure the via_address because it defaulted to, and was included in the SIP contact header, and the SDP too :slight_smile:

Is the “call me” button supposed to work on red5plugin 0.0.27?

What version of OpenLaszlo was used to compile the phoneApi.lzx?

The working directory as the root for all file access is proving to be a problem for Linux users as it seems the web server (Jetty) can be started from anywhere causing the relative file pointers to all fail.

Any suggestions?

call me button is supposed to be working. I have not tested in release 0.0.27. is it broken?

I believe I am using Openlaszlo war version for Tomcat version 3.4

I always start openfire like so:

cd /opt/openfire

sudo ./bin/openfire start

No problem with logging at all. Tried Ubuntu (feisty) and Debian (etch+java6 from lenny) on x86.

(my experience with the log directory sensitivity of red5phone is from when I tried to make it run standalone.)

Side-thread on CallMe and Openlaszlo:

CallMe did not work right away when the flex client did, I’ll investigate today, could be my via_addr hack.

And I got strange compilation errors from the openlaszlo compiler against its own RTMP support library with 4.1 last time I tried.

Meta-thread on sharing and helping each other:

This is what makes open source tick afterall. (among other things)

Thanks for the advice !

So, I changed the …openfire/plugins/red5/red5phone/sip.cfg with log_path=/tmp

I have restarted openfire.

Yet the problem is still the same : no log file is created and no SIP messages are sent…

I don’t know if that make a big difference, but I installed openfire 3.5.2 from the .deb packahe, using dpkg -i openfire… (on an etch with Java 6 from Lenny as well)

So the install directory is /usr/share/openfire/ (with no bin directory) and I start and stop it with /etc/init.d/openfire start/stop

Very strange… So, just for me to now : did you manage to make the red5phone with the standalone server (I do not need openfire neither, so that would be the best for me). If it is so, could you please give me the exact procedure for the installation with the version of each part (I read that the red5phone doesn’t work with the last version of the red5 server) and the files you had to modify ?

Thanks a lot !


I guess that’s the difference then, why don’t you try to install manually to a separate location?

That won’t interfere with the managed installation unless you run the two at the same time.

No, I never got it working standalone, for my current purposes the ignite plugin is fine.

I’d prefer to work with trunk head of red5 of course, but I guess I can wait for 0.7.1 to be released.

Thanks for your good advise. When you say that I should install it manually, what do you mean exactly ? To install it from the source ? By any chance, could you give me few hints on the way you did it ?

Thanks again,


By manually I meant without the package manager (apt).

This way all files end up under /opt/openfire (config, logs, everything) so it’s safe to experiment.

I folowed this and worked both on debian and ubuntu:

Thanks, that’s whas the thing : the installation from the deb package doesn’t allow the red5phone to work properly. Installing it with what is said on the document works perfectly

Thanks again for your help !!