powered by Jive Software

Refreshing Title in Spark using openfire

Hello,

We are using openfire 4.5.1 and Spark client 2.8.3 and I am having an issue with the title information coming back over from ad. When a user first log’s in the information is populated. But, if they have a title change it doesn’t change. I have tried clearing the cache and rebooting the server. Neither have worked. I also, just tried to clear the fold in app data on the users computer. Is there something else I can try to flush in the information?

What title is that exactly, and where do you see this information? Can you perhaps show some screenshots?

profile

The title field from the profile in spark chat

Hmm, there can be various places where this is cached.

You can rule out a Spark issue by trying to use Spark on a different computer.

For Openfire, I’d first try to flush the cache called “VCards” through the admin console of Openfire. LDAP results are cached for some time as well though, so that might still cause something to linger. In any case, restarting Openfire should take care of that.

I actually flushed all of the cached files, and then restarted the server. Nothing changed.

Try installing Spark on a completely different computer. If the title is still “wrong” there, we’ve ruled out Spark as a culprit.

k tried it on another machine I have not used Spark on. Same result.

Do you have more than one domain controller? If so, check the domain controller that openfire is using. Has replication completed?

Yep verified they are syncing and I connected to each one and checked the title. All of them are correct

can you look at your openfire system properties and tell me what you have for vcard provider (dont recall the exact name)

Yep. Under

provider.vcard.className

org.jivesoftware.openfire.vcard.DefaultVCardProvider

I believe that is your issue. try changing it to.
org.jivesoftware.openfire.ldap.LdapVCardProvider

The default provider is reading from the local database, and not from ldap.

2 Likes

That works thanks.