powered by Jive Software

Reinstalling/New install

I am at a loss and will just start from the beginning. I apologize if this has been answered already somewhere but I cannot seem to find the right path to take.

Everything was working fine until an associate of mine decided the only way to fix an error was to uninstall Openfire from our server and attempt to reinstall it.

  • I do not know what the issue was
  • I do not know what the settings used to be as it was originally setup by someone else
  • I do not know anything about the old database

He attempted to reinstall and was met with the same issue I am having which is we cannot access the admin console. We keep getting password incorrect for the admin user. I have uninstalled the program and changed the name of the C:\programfiles x86\openfire folder name to Openfire.org so that a fresh install could happen. Now as I have never set this up I wanted to make it as simple as possible so I choose to use the embedded database and the simple password options, not LDAP. When I get to the final screen of the setup wizard I am met with an “old password” box and also “email, new password, confirm password” boxes. I have tried the default password “admin” and may other passwords but they all fail. I have also tried to “skip” that step and log directly into the console with “admin” user and “admin” password but all efforts fail.

I have done some searching and found other threads that talk about editing the openfire.xml file and adding users that could be admins. However, I do not know what any of those users could have been so I thought I would add the lines of code and put the user “admin”.

Now since all efforts failed on my server I decided that I would try to install Openfire on my personal laptop just to see if I could get past this mess and into the admin console however, I was met with the exact same issue.

I need some direction as to how to handle this issue. I need to get Openfire installed and spark attached to it for a handful of users and I would just switch to slack or skype but we are not wanting a new solution.

Other points that may help direct me:

  • I see no Openfire services in the services menu on the server or my laptop
  • Every time I close the wizard it re-runs when I try again
  • I can add a user by editing the xml file but I cannot seem to find where to add the password
  • Some threads have said that on first run they do not get an “old Password” option but i do every time and on both Server and Laptop installations
  • My server user is part of the Domain admins group and enterprise admins group
  • My laptop i am the only user which is an admin account

Thank you in advance

I would like to update this. I tried one more time to run through the setup but this time I was logged in as the Domain Administrator rather than a user that was part of the Domain Admin group. I was able to run the wizard, reset the password, and log right into the admin console. I do not know what the breakdown was but it was some weird permissions issue i guess that was preventing the wizard from running correctly. If I have any more hold ups I will return.